Anonymous Login
2019-12-07 14:45 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000325v3.2 ReleaseEventspublic2014-08-16 18:58
Reportermisjka 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target Version3.2Fixed in Version3.2 
Summary0000325: Bug in code for uploading files
DescriptionHi!

As it seems w2p has inherited the following code bug from dP:

In modules/files/files.class.php, row 291-293, the "backquotes" (`) should be replaced with "normalquotes" ('). Else, the code generates an error on my server at least, complaining about shell_exec not being allowed.

            $x = `$parser -`;
        } else {
            $x = `$parser`;

shoud be changed to

            $x = '$parser -';
        } else {
            $x = '$parser';
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000631

caseydk (administrator)

You have the shell_exec permissions blocked which is causing the error.

I think we need to rework the parsing in general to handle numerous file parsers regardless of the underlying permissions or the operating system itself.

~0000634

misjka (reporter)

Last edited: 2009-12-07 21:55

> You have the shell_exec permissions blocked which is causing the error.
> I think we need to rework the parsing in general to handle numerous file parsers regardless of the underlying permissions or the operating system itself.

Yes, I'm aware of the blocked shell exec permission but I believe it's quite common among commercial/public webhosts to have that setting?
The parsing rework sounds great!

~0002073

caseydk (administrator)

I've applied a patch in r2008 that will suppress this error since there's not a clean way to approach it at the moment.

~0003439

caseydk (administrator)

Resolved in development:
https://github.com/web2project/web2project/commit/c1852d8863abc7a0802763627b6dd520447b58d8
+Notes

-Issue History
Date Modified Username Field Change
2009-12-07 07:00 misjka New Issue
2009-12-07 18:45 caseydk Project v1.1 Release (Closed) => v1.2 Release (Closed)
2009-12-07 20:30 caseydk Note Added: 0000631
2009-12-07 20:30 caseydk Status new => feedback
2009-12-07 20:31 caseydk Project v1.2 Release (Closed) => Pending Requests
2009-12-07 21:55 misjka Note Added: 0000634
2009-12-07 21:55 misjka Note Edited: 0000634
2010-01-31 22:33 caseydk Category -- none specified -- => Files
2011-02-24 01:03 caseydk Project Pending Requests => v2.4 Release (Closed)
2011-07-23 20:15 caseydk Project v2.4 Release (Closed) => Pending Requests
2011-07-23 20:16 caseydk Note Added: 0002073
2014-06-11 18:07 caseydk Project Pending Requests => v3.2 Release
2014-06-11 18:07 caseydk Category General => Calendar
2014-06-11 18:07 caseydk Product Version 1.1 =>
2014-06-11 18:07 caseydk Fixed in Version => 3.2
2014-06-11 18:07 caseydk Target Version => 3.2
2014-06-11 18:08 caseydk Note Added: 0003439
2014-06-11 18:08 caseydk Status feedback => resolved
2014-06-11 18:08 caseydk Resolution open => fixed
2014-06-11 18:08 caseydk Assigned To => caseydk
2014-07-16 21:31 caseydk Status resolved => closed
2014-08-16 18:58 caseydk Category Calendar => Events
+Issue History