Anonymous Login
2018-10-17 03:01 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000331v1.2 Release (Closed)[All Projects] Generalpublic2010-01-06 19:52
ReporterKrzysztofKamil 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version1.2.1 
Summary0000331: Contact edit form is blank
DescriptionIt appears after solving this issue http://bugs.web2project.net/view.php?id=330
Now I can edit contact after installing. But the next time, when I want change sth - form is blank although data in profile summary are displayed correctly.
Tagsr900
Attached Files

-Relationships
+Relationships

-Notes

~0000650

caseydk (administrator)

Which form is empty? The contact info form itself?

~0000651

KrzysztofKamil (reporter)

Yep. All of fields in contact form are empty.

~0000672

caseydk (administrator)

I've been trying to duplicate this one and I'm not getting it... could you provide all the steps? Thanks.

~0000678

KrzysztofKamil (reporter)

So, step by step.
1. Clean install of w2p v1.2 with fix that you pointed me on the board.
2. I put my info into form, the most important of them (name, e-mail, IM, country, job title, displayed name).
3. Save the info.
4. Now everything is displayed correctly at the contact page.
5. When I want edit info, it seems that script didn't get info from database. Form fields are blank.
IMO script of editing contact has problems with reading database. Maybe it's about some incorrect settings in DB, there appears few during installation...

~0000683

caseydk (administrator)

Still not able to reproduce this one. Has anyone else duplicated this?

~0000693

engral (reporter)

similar problem for me after modifying script according http://bugs.web2project.net/view.php?id=330
form is blank

~0000694

KrzysztofKamil (reporter)

Last edited: 2009-12-26 19:44

Finally! Someone has the same ugly bug!
Sorry, engral ;)

Hmm... I noticed that form is OK, if I opening somebody with granted manager role.
ACL for this role I described in the first post (x_manager) at http://forums.web2project.net/viewtopic.php?t=1497
But if open contact of somebody with "x_worker" role, form fields are blank.

I forgot to mention before that I've got one custom fields in contacts.

~0000696

engral (reporter)

Hello KrzysztofKamil.
I don't understand your answer because my bad english...
But it seem's to be OK with http://www.demval.com/ftp/web2project-trunk-revision-894-2009-12-27.zip
I'll try it soon on my server.

~0000698

KrzysztofKamil (reporter)

OK. Write if it would works.

~0000702

caseydk (administrator)

Resolved this one in r900;
The permissions check was exactly opposite of what it should have been... this fix will be in the v1.2.1 release;

~0000730

caseydk (administrator)

In v1.2.1 release.
+Notes

-Issue History
Date Modified Username Field Change
2009-12-14 03:08 KrzysztofKamil New Issue
2009-12-14 03:32 caseydk Note Added: 0000650
2009-12-14 03:36 KrzysztofKamil Note Added: 0000651
2009-12-17 22:09 caseydk Assigned To => caseydk
2009-12-17 22:09 caseydk Severity minor => major
2009-12-17 22:09 caseydk Status new => assigned
2009-12-17 22:10 caseydk Project Pending Requests => v1.2 Release (Closed)
2009-12-19 17:36 caseydk Note Added: 0000672
2009-12-20 06:04 KrzysztofKamil Note Added: 0000678
2009-12-23 21:06 caseydk Note Added: 0000683
2009-12-26 16:01 engral Note Added: 0000693
2009-12-26 19:37 KrzysztofKamil Note Added: 0000694
2009-12-26 19:44 KrzysztofKamil Note Edited: 0000694
2009-12-27 09:17 engral Note Added: 0000696
2009-12-27 12:15 KrzysztofKamil Note Added: 0000698
2009-12-29 20:38 caseydk Status assigned => resolved
2009-12-29 20:38 caseydk Resolution open => fixed
2009-12-29 20:38 caseydk Note Added: 0000702
2010-01-06 19:52 caseydk Note Added: 0000730
2010-01-06 19:52 caseydk Status resolved => closed
2010-01-06 19:52 caseydk Fixed in Version => 1.2.1
2010-04-05 23:57 ronaldo_ronaldo Tag Attached: r900
+Issue History