Anonymous Login
2019-08-20 01:29 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000340v2.0 Release (Closed)[All Projects] Generalpublic2010-06-21 21:18
Reporteregemme 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Versionv2.0.0 
Summary0000340: The date class throws logs
DescriptionI just noticed in my Zend CE log that this message appears in large number of entries:

[22-Dec-2009 21:07:05] PHP Warning: date_default_timezone_get() [<a href='function.date-default-timezone-get'>function.date-default-timezone-get</a>]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for '-5.0/no DST' instead in C:\Program Files\Zend\Apache2\htdocs\web2project\classes\date.class.php on line 44

You may recall I once had some TZ problems on my setup and finally tweaked Zend to get proper time. By curiosity, I set back the date.timezone property to blank on my server. Time is shown correctly on screen (don't know why) but logging is still clogged with the hereabove warning.

TIA
TagsNo tags attached.
Attached Files

-Relationships
child of 0000337assignedcaseydk v4.0 Release (Planning) Replace PEAR/Date 
child of 0000221closedcaseydk v2.0 Release (Closed) PHP5.3 Deprecation Testing 
+Relationships

-Notes

~0000679

caseydk (administrator)

You're seeing the 5.3 E_DEPRECATED warnings. While they're 'not good', they're 'not bad' either. Since the v1.2 release, I've scrubbed all of the core application and a few places here and there, so we should be pretty good.

The problematic part is the PEAR/Date library. The library as a whole has been deprecated in favor of core PHP functionality but - as noted on 0000337 - this functionality was spread between various PHP 5.2 and 5.3 versions, so it's going to be tough.

~0000845

caseydk (administrator)

This is resolved in commits r1041-1047 and will be in the v2.0 release. Other TZ-related issues may still persist.
+Notes

-Issue History
Date Modified Username Field Change
2009-12-22 12:08 egemme New Issue
2009-12-23 05:19 caseydk Relationship added child of 0000337
2009-12-23 05:20 caseydk Relationship added child of 0000221
2009-12-23 05:22 caseydk Note Added: 0000679
2009-12-23 05:22 caseydk Project v1.3 Release (Closed) => Pending Requests
2010-01-31 07:51 caseydk Project Pending Requests => v2.0 Release (Closed)
2010-05-01 16:28 caseydk Note Added: 0000845
2010-05-01 16:28 caseydk Status new => resolved
2010-05-01 16:28 caseydk Resolution open => fixed
2010-05-01 16:28 caseydk Assigned To => caseydk
2010-06-21 21:18 caseydk Status resolved => closed
2010-06-21 21:18 caseydk Fixed in Version => v2.0
+Issue History