Anonymous Login
2018-10-17 03:09 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000351v1.2 Release (Closed)[All Projects] Generalpublic2010-01-06 19:52
Reporterhmoosani 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
Product Version1.2 
Target VersionFixed in Version1.2.1 
Summary0000351: Create User
DescriptionWhen I create/update a user, I get the following error but the user is created anyway.

ERROR: /home/ihari/public_html/web2project/classes/query.class.php(1169) : query failed(INSERT INTO `history`(`history_action`,`history_item`,`history_description`,`history_user`,`history_date`,`history_project`,`history_table`) VALUES ('store',NULL,'','1',NOW(),NULL,'contacts')) - error was: Column 'history_item' cannot be null
Backtrace:
0 /home/ihari/public_html/web2project/classes/query.class.php:1169 dprint('/home/ihari/public_html/web2project/classes/query.class.php',1169,0,'query failed(INSERT INTO `history`(`history_action`,`history_item`,`history_description`,`history_user`,`history_date`,`history_project`,`history_table`) VALUES (\'store\',NULL,\'\',\'1\',NOW(),NULL,\'contacts\')) - error was: Column \'history_item\' cannot be null')
1 /home/ihari/public_html/web2project/includes/main_functions.php:700 exec()
2 /home/ihari/public_html/web2project/modules/contacts/contacts.class.php:118 addHistory('contacts',NULL,'store',NULL,NULL)
3 /home/ihari/public_html/web2project/modules/admin/do_user_aed.php:76 store(CAppUI::__set_state(array(
   'state' =>
  array (
    'CalIdxCompany' => 0,
    'CalIdxFilter' => '',
    'CalDayViewTab' => 0,
    'SAVEDPLACE-1' => 'm=admin',
    'SAVEDPLACE' => 'm=admin&a=viewuser&user_id=3&tab=1',
    'UserIdxTab' => 0,
    'addProjWithTasks' => 0,
    'UsrProjIdxCompany' => '0',
    'UserVwTab' => 1,
  ),
   'user_id' => '1',
   'user_first_name' => 'Hari',
   'user_last_name' => 'Moosani',
   'user_company' => '0',
   'user_department' => '0',
   'user_email' => 'admin@ihari.com',
   'user_type' => '1',
   'user_prefs' =>
  array (
    'CURRENCYFORM' => 'en',
    'EVENTFILTER' => 'my',
    'LOCALE' => 'en',
    'MAILALL' => '0',
    'SHDATEFORMAT' => '%m/%d/%Y',
    'TABVIEW' => '0',
    'TASKASSIGNMAX' => '100',
    'TASKLOGEMAIL' => '0',
    'TASKLOGNOTE' => '0',
    'TASKLOGSUBJ' => '',
    'TIMEFORMAT' => '%I:%M %p',
    'UISTYLE' => 'web2project',
    'USERFORMAT' => 'user',
    'TASKSEXPANDED' => '0',
  ),
   'day_selected' => NULL,
   'user_locale' => 'en',
   'user_lang' =>
  array (
    0 => 'en.ISO8859-15',
    1 => 'enu',
    2 => 'en',
    3 => 'en',
  ),
   'base_locale' => 'en',
   'msg' => 'User',
   'msgNo' => 0,
   'defaultRedirect' => '',
   'cfg' =>
  array (
    'locale_warn' => false,
  ),
   'version_major' => 1,
   'version_minor' => 2,
   'version_patch' => 0,
   'version_string' => '1.2.0',
   'last_insert_id' => '3',
   'user_style' => NULL,
   'user_is_admin' => 1,
   'objStore' => NULL,
   'project_id' => 0,
   'boxTopRendered' => true,
)))
4 /home/ihari/public_html/web2project/index.php:253 require('/home/ihari/public_html/web2project/modules/admin/do_user_aed.php')
Column 'history_item' cannot be null
TagsNo tags attached.
Attached Files

-Relationships
duplicate of 0000330closedcaseydk Can't add/edit contacts 
+Relationships

-Notes

~0000717

caseydk (administrator)

While this appears to be a different issue, it's actually a duplicate of 0000330. The same fix that was applied there fixes this one. It will be in the v1.2.1 release.

~0000729

caseydk (administrator)

In v1.2.1 release.
+Notes

-Issue History
Date Modified Username Field Change
2010-01-05 16:58 hmoosani New Issue
2010-01-05 19:16 caseydk Relationship added duplicate of 0000330
2010-01-05 19:16 caseydk Duplicate ID 0 => 330
2010-01-05 19:16 caseydk Status new => resolved
2010-01-05 19:16 caseydk Resolution open => duplicate
2010-01-05 19:16 caseydk Assigned To => caseydk
2010-01-05 19:16 caseydk Note Added: 0000717
2010-01-06 19:52 caseydk Note Added: 0000729
2010-01-06 19:52 caseydk Status resolved => closed
2010-01-06 19:52 caseydk Fixed in Version => 1.2.1
+Issue History