Anonymous Login
2019-12-15 07:52 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000365v1.3 Release (Closed)[All Projects] Generalpublic2010-03-31 22:43
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version1.3 
Target VersionFixed in Version1.3 
Summary0000365: task_priority treated as string
Descriptionif task_priority=0,
then ::task->check() which is called in store() throws an error in

if ($this->task_priority == '') {
         $errorArray['task_priority'] = $baseErrorMsg . 'task priority is NULL';



everything is ok if

if task_priority='0'.

strangely enough,

task_priority=1 (or other integers) work.


The following claims to work with 0 and '0':

in cases when "0" is not intended to be empty, here is a simple function to safely test for an empty string (or mixed variable):


function _empty($string){
     $string = trim($string);
     if(!is_numeric($string)) return empty($string);
     return FALSE;
}
  


from

http://php.net/manual/de/function.empty.php

Klaus
Additional Informationhttp://forums.web2project.net/viewtopic.php?t=1644
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000776

caseydk (administrator)

Resolved in r968

~0000810

caseydk (administrator)

Closed in v1.3 release.
+Notes

-Issue History
Date Modified Username Field Change
2010-02-01 22:27 opto New Issue
2010-03-27 20:42 caseydk Note Added: 0000776
2010-03-27 20:42 caseydk Status new => resolved
2010-03-27 20:42 caseydk Resolution open => fixed
2010-03-27 20:42 caseydk Assigned To => caseydk
2010-03-31 22:43 caseydk Note Added: 0000810
2010-03-31 22:43 caseydk Status resolved => closed
2010-03-31 22:43 caseydk Fixed in Version => 1.3
2010-03-31 22:43 caseydk Product Version => 1.3
+Issue History