Anonymous Login
2019-12-12 21:05 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000366v1.3 Release (Closed)[All Projects] Generalpublic2010-03-31 22:41
Reporterclement 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version1.3 
Summary0000366: Duplicate entry in task_departments on new task submission
DescriptionERROR: /home/www/dmd.vhosts/w2p/web2project/classes/query.class.php(1169) : query failed(INSERT INTO `task_departments`(`task_id`,`department_id`) VALUES ('15','1')) - error was: Duplicate entry '15-1' for key 1
Backtrace:
0 /home/www/dmd.vhosts/w2p/web2project/classes/query.class.php:1169 dprint('/home/www/dmd.vhosts/w2p/web2project/classes/query.class.php',1169,0,'query failed(INSERT INTO `task_departments`(`task_id`,`department_id`) VALUES (\'15\',\'1\')) - error was: Duplicate entry \'15-1\' for key 1')
1 /home/www/dmd.vhosts/w2p/web2project/modules/tasks/tasks.class.php:612 exec()
2 /home/www/dmd.vhosts/w2p/web2project/modules/tasks/do_task_aed.php:156 store(CAppUI::__set_state(array(
   'state' =>
  array (
    'SAVEDPLACE-1' => 'm=tasks&a=view&task_id=14',
    'SAVEDPLACE' => 'm=projects&a=view&project_id=2',
    'ProjIdxTab' => 1,
    'ProjIdxCompany' => '1',
    'ProjIdxOrderDir' => 'asc',
    'ProjVwTab' => 0,
    'TaskListShowIncomplete' => 0,
    'TaskLogVwTab' => 0,
    'TaskAeTabIdx' => 0,
  ),
   'user_id' => '4',
   'user_first_name' => 'User',
   'user_last_name' => 'NAME',
   'user_company' => '1',
   'user_department' => '1',
   'user_email' => 'some_user@example.com',
   'user_type' => '6',
   'user_prefs' =>
  array (
    'CURRENCYFORM' => 'en',
    'EVENTFILTER' => 'all',
    'LOCALE' => 'fr_FR',
    'MAILALL' => '0',
    'SHDATEFORMAT' => '%d/%m/%Y',
    'TABVIEW' => '0',
    'TASKASSIGNMAX' => '100',
    'TASKLOGEMAIL' => '0',
    'TASKLOGNOTE' => '0',
    'TASKLOGSUBJ' => '',
    'TIMEFORMAT' => '%H:%M',
    'UISTYLE' => 'wps-redmond',
    'USERFORMAT' => 'user',
    'TASKSEXPANDED' => '0',
  ),
   'day_selected' => NULL,
   'user_locale' => 'fr',
   'user_lang' =>
  array (
    0 => 'fr_FR.utf-8',
    1 => 'fra',
    2 => 'fr_FR',
    3 => 'fr',
  ),
   'base_locale' => 'en',
   'msg' => '',
   'msgNo' => 0,
   'defaultRedirect' => '',
   'cfg' =>
  array (
    'locale_warn' => false,
  ),
   'version_major' => 1,
   'version_minor' => 2,
   'version_patch' => 2,
   'version_string' => '1.2.2',
   'last_insert_id' => '78',
   'user_style' => NULL,
   'user_is_admin' => 0,
   'objStore' => NULL,
   'project_id' => 0,
   'boxTopRendered' => false,
)))
3 /home/www/dmd.vhosts/w2p/web2project/index.php:253 require('/home/www/dmd.vhosts/w2p/web2project/modules/tasks/do_task_aed.php')
Additional InformationLooks like issue 0000327, but with version 1.2.2

Issue occured two times today, and i've not managed to reproduce it yet.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000744

caseydk (administrator)

I moved this to v1.3 as this is the next release (0000013:0000035 days).

~0000778

caseydk (administrator)

Please go to the w2pversion table in your database and see what the maximum value of the db_version field is. This problem was resolved in database update 12 which was in the v1.1 release.

~0000794

caseydk (administrator)

Marking this one as resolved since no one has been able to reproduce it since database update 12 in v1.1

~0000800

caseydk (administrator)

Closed in v1.3 release.
+Notes

-Issue History
Date Modified Username Field Change
2010-02-02 05:30 clement New Issue
2010-02-02 22:39 caseydk Status new => assigned
2010-02-02 22:39 caseydk Assigned To => caseydk
2010-02-02 22:40 caseydk Project v1.2 Release (Closed) => v1.3 Release (Closed)
2010-02-02 22:40 caseydk Note Added: 0000744
2010-03-27 22:05 caseydk Note Added: 0000778
2010-03-31 20:29 caseydk Note Added: 0000794
2010-03-31 20:29 caseydk Status assigned => resolved
2010-03-31 20:29 caseydk Resolution open => fixed
2010-03-31 22:41 caseydk Note Added: 0000800
2010-03-31 22:41 caseydk Status resolved => closed
2010-03-31 22:41 caseydk Fixed in Version => 1.3
+Issue History