Anonymous Login
2019-12-08 18:50 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000397v1.3 Release (Closed)[All Projects] Generalpublic2010-03-31 22:42
Reporteregemme 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version1.3 
Summary0000397: w2p_textarea function messes-up accents in file_description on files/index_table.php
DescriptionThe only thing I could notice is that the file_description field is a blob. Otherwise, w2p_textarea works fine elsewhere
TagsNo tags attached.
Attached Files

-Relationships
related to 0000381closedcaseydk After uploading the SVN version 967 of 1.22 in the names appeared to be wrong (incorrect code pages) 
+Relationships

-Notes

~0000773

caseydk (administrator)

I'm looking at the file_description in my install and it's medium_text which is the same as the company_description. Also, looking at the base sql install (around line 448), it's a text field.

Are you 100% sure it's only on that field?

~0000779

egemme (reporter)

Ok first, I misled you with the blob. You're right, they are medium text. I thought of a blob because of the little superscipt note MySQL Workbench query result shows whenever a field is null or too long long to display. When it's too long, it shows "BLOB" in place of the value which is confusing.

Now, you're right again to raise the fact the problem may exist elsewhere. project_description which is also a medium text gets its accents messed-up after going thru w2p_textarea which visibly doesn't support this data type well. text based data type must use different binary format or something unlike varchar that utf8 trip on.

~0000798

caseydk (administrator)

Fixed in r989. Here is the test snippet:

0196 Ä = AE (capital)
0228 ä = ae (small)
0203 Ë = EE (capital)
0235 ë = ee (small)
0214 Ö = OE (capital)
0246 ö = oe (small)
0220 Ü = UE (capital)
0252 ü = ue (small)
0223 ß = SS

~0000802

caseydk (administrator)

Closed in v1.3 release.
+Notes

-Issue History
Date Modified Username Field Change
2010-03-26 11:35 egemme New Issue
2010-03-27 05:06 caseydk Note Added: 0000773
2010-03-28 04:29 egemme Note Added: 0000779
2010-03-28 21:54 caseydk Project v1.2 Release (Closed) => v1.3 Release (Closed)
2010-03-31 21:37 caseydk Relationship added related to 0000381
2010-03-31 21:53 caseydk Note Added: 0000798
2010-03-31 21:53 caseydk Status new => resolved
2010-03-31 21:53 caseydk Resolution open => fixed
2010-03-31 21:53 caseydk Assigned To => caseydk
2010-03-31 22:42 caseydk Note Added: 0000802
2010-03-31 22:42 caseydk Status resolved => closed
2010-03-31 22:42 caseydk Fixed in Version => 1.3
+Issue History