Anonymous Login
2020-10-28 18:57 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000427v2.0 Release (Closed)[All Projects] Generalpublic2010-05-19 15:48
Reporterpatrocher 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000427: Sub Project doesn't show up in Project list if user has no permission to parent project
DescriptionLet's say you have a project P1 and you want to allow a guest access to only part of it. If you create a subproject P1.public and you grant your special guest access to this P1.public project, he will be able to see associated tasks, forums, files (admitted you grant him permission to these modules).
But the said P1.bublic doesn't appear in the project list ! (even if the tabs indicate that there is (1) project that he has access to (I believe it's because he doesn't have the permission for the parent project P1).

Curiously he may access to P1.public through the task list if he was assigned a task of P1.public.
It would make sense to display the subproject P1.public in the project list.
TagsNo tags attached.
Attached Files

-Relationships
duplicate of 0000415closedtrevormorse Project count on tabs different 
has duplicate 0000428closedcaseydk Sub Project doesn't show up in Project list if user has no permission to parent project 
+Relationships

-Notes

~0000857

caseydk (administrator)

This is actually the same as 0000415, you were just seeing a different set of symptoms.

The good news is that it's already fixed for the coming v2.0 release.. the bad news is that you still have about 8 weeks until that's released. Five weeks until the release candidate..
+Notes

-Issue History
Date Modified Username Field Change
2010-05-05 11:14 patrocher New Issue
2010-05-05 18:12 caseydk Relationship added has duplicate 0000428
2010-05-05 18:14 caseydk Note Added: 0000857
2010-05-05 18:14 caseydk Relationship added duplicate of 0000415
2010-05-05 18:14 caseydk Duplicate ID 0 => 415
2010-05-05 18:14 caseydk Status new => resolved
2010-05-05 18:14 caseydk Resolution open => duplicate
2010-05-05 18:14 caseydk Assigned To => caseydk
2010-05-06 05:12 caseydk Project Pending Requests => v2.0 Release (Closed)
2010-05-19 15:48 caseydk Status resolved => closed
+Issue History