2017-11-20 05:29 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000447v2.0 Release (Closed)[All Projects] Generalpublic2010-06-21 21:09
Reporterbourbaki007 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Versionv2.0.0 
Summary0000447: User Log Date Time IN - Date Time OUT: swapped values
DescriptionOn the same report:
                        Date Time IN Date Time OUT
Admin Person 2010-05-19 11:20:42 2010-05-19 13:38:44
Admin Person 2010-05-06 09:57:07 2010-05-06 09:29:53

The first line makes sense.
The second one is wrong since 09:57:07 comes after 09:29:53.
It should be 09:29:53 as IN and 09:57:07 as OUT Time.

Curious: some lines of the same report are ok, others are wrong.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000908

caseydk (administrator)

I haven't been able to reproduce this one..

Are these all for the same user? Are you using the same computer each time? Is this the same browser each time?

~0000919

bourbaki007 (reporter)

I tried again on the same computer and on another one.
The same behavior on each one. Also with different w2p users.
Also on two different servers (w2p installations): a "real" one (linux) and a virtual machine (XP) on localhost (XP).

Playing around it appears that it's a time shifting issue instead of swapping time values:
When my computer clock shows 10:01, I log into w2p and see that Date Time IN displays 10:31. It's like a forward shift of 30 min.

It seems that also some shifting occurs to Time OUT because while my computer clock shows 11:31 I get on a different log line:
Admin Person 2010-05-31 11:33:03 2010-05-31 11:54:08

The two servers I tried are in time sync.
I'm using Firefox 3.6.3 on Win XP with cookies enabled, but deleting them when exiting.

w2p settings for Admin user:
Locale: english
Timezone: GMT+1 Europe/Vienna
Daylight Savings?: yes
        As of web2project v1.3, timezones are included for information purposes only.No calculations or displayes are affected by setting a timezones.
Tabbed Box View: either
Short Date Format: 31/May/2010
Time Format: 10:29 am

~0000973

caseydk (administrator)

I've tracked down the core of this one. After you've upgraded to database version 19 or above, go into System Admin -> System Configuration and make sure your System Timezone is set properly.

To be clear, this is supposed to be the Timezone of the server itself.
+Notes

-Issue History
Date Modified Username Field Change
2010-05-25 01:58 bourbaki007 New Issue
2010-05-25 12:17 caseydk Project v1.3 Release (Closed) => v2.0 Release (Closed)
2010-05-29 21:53 caseydk Note Added: 0000908
2010-05-29 21:53 caseydk Status new => feedback
2010-05-31 02:25 bourbaki007 Note Added: 0000919
2010-06-06 10:31 caseydk Note Added: 0000973
2010-06-06 10:31 caseydk Status feedback => resolved
2010-06-06 10:31 caseydk Resolution open => fixed
2010-06-06 10:31 caseydk Assigned To => caseydk
2010-06-21 21:09 caseydk Status resolved => closed
2010-06-21 21:09 caseydk Fixed in Version => v2.0
+Issue History