2017-11-20 05:26 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000463v2.0 Release (Closed)[All Projects] Generalpublic2010-06-21 21:08
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Versionv2.0.0 
Target VersionFixed in Versionv2.0.0 
Summary0000463: Unknown column 'contact_email' in 'field list'
Descriptionfor projects, tasks I get theis error after copying over the latest PHP (100605, 00:56) and running the upgrade script via system admin.

error message:

C:\xampp\htdocs\w2pd05\classes\w2p\Database\Query.class.php(1109): query failed(SELECT c.contact_id, contact_first_name, contact_last_name, contact_email, contact_order_by,contact_phone, dept_name FROM ((`contacts` AS c)) INNER JOIN `project_contacts` AS pc ON pc.contact_id = c.contact_id LEFT JOIN `departments` AS d ON d.dept_id = c.contact_department WHERE pc.project_id = 9 AND (contact_private=0 OR (contact_private=1 AND contact_owner=1) OR contact_owner IS NULL OR contact_owner = 0 )) - error was: Unknown column 'contact_email' in 'field list'

ERROR: C:\xampp\htdocs\w2pd05\classes\w2p\Database\Query.class.php(1109) : query failed(SELECT c.contact_id, contact_first_name, contact_last_name, contact_email, contact_order_by,contact_phone, dept_name FROM ((`contacts` AS c)) INNER JOIN `project_contacts` AS pc ON pc.contact_id = c.contact_id LEFT JOIN `departments` AS d ON d.dept_id = c.contact_department WHERE pc.project_id = 9 AND
                (contact_private=0
                    OR (contact_private=1 AND contact_owner=1)
                    OR contact_owner IS NULL OR contact_owner = 0
                )) - error was: Unknown column 'contact_email' in 'field list'
Backtrace:
0 C:\xampp\htdocs\w2pd05\classes\w2p\Database\Query.class.php:1109 dprint()
1 C:\xampp\htdocs\w2pd05\classes\w2p\Database\Query.class.php:1174 exec()
2 C:\xampp\htdocs\w2pd05\modules\projects\projects.class.php:722 loadHashList()
3 C:\xampp\htdocs\w2pd05\modules\projects\view.php:279 getContacts()
4 C:\xampp\htdocs\w2pd05\index.php:362 require()
Unknown column 'contact_email' in 'field list'

Klaus

TagsNo tags attached.
Attached Files

-Relationships
related to 0000466closedcaseydk Reorg of contacts with contacts_methods broke smartsearch 
+Relationships

-Notes

~0000962

opto (manager)

doublechecked: this field (contact_email) is definitely not there.

realised that sql update 21 drops this and other fields.
So maybe something else is unfinished or broken.

~0000966

caseydk (administrator)

There were a LOT of these, but I just tracked down and cleaned up all of them in commits up through r1164.

~0000970

opto (manager)

Last edited: 2010-06-06 01:25

searching for contact_email in all files still gives many occurrences.

login is broken, also view of a project or view of a task.

Maybe I have an incomplete version? Or caused by dP upgrade?

I downloaded the tarball offered at http://web2project.svn.sourceforge.net/viewvc/web2project/

because:
if I try tortoisesvn or svn (sliksvn) from http://web2project.svn.sourceforge.net/viewvc/web2project/trunk/, I get:

Error: Repository moved temporarily to '/viewvc/web2project/trunk/'; please relocate
as I haven't checked out any yet, how can I relocate?

I don't understand this message.

I can check out others (e.g. weberp)

As I did log out and can't login any more, unfortunately, I cannot post any error messages (other than the login message):

C:\xampp\htdocs\w2pd05\classes\w2p\Database\Query.class.php(1109): query failed(SELECT user_id, contact_first_name as user_first_name, contact_last_name as user_last_name, contact_company as user_company, contact_department as user_department, contact_email as user_email, user_type FROM ((`users` AS users)) INNER JOIN `contacts` AS con ON contact_id = user_contact WHERE user_id = 1 AND user_username = 'admin') - error was: Unknown column 'contact_email' in 'field list'

ERROR: C:\xampp\htdocs\w2pd05\classes\w2p\Database\Query.class.php(1109) : query failed(SELECT user_id, contact_first_name as user_first_name, contact_last_name as user_last_name, contact_company as user_company, contact_department as user_department, contact_email as user_email, user_type FROM ((`users` AS users)) INNER JOIN `contacts` AS con ON contact_id = user_contact WHERE user_id = 1 AND user_username = 'admin') - error was: Unknown column 'contact_email' in 'field list'
Backtrace:
0 C:\xampp\htdocs\w2pd05\classes\w2p\Database\Query.class.php:1109 dprint()
1 C:\xampp\htdocs\w2pd05\classes\w2p\Database\Query.class.php:1256 exec()
2 C:\xampp\htdocs\w2pd05\classes\ui.class.php:757 loadObject()
3 C:\xampp\htdocs\w2pd05\index.php:126 login()
Unknown column 'contact_email' in 'field list'


my AppUI->login still has the contact_email in the sql, but maybe my PHP files are nt up to date?



Klaus

~0000971

caseydk (administrator)

The contact_email field is used as an alias now. If you look for the occurances, it should say something like "method_value as contact_email". This allows the queries behind the scenes to change but the rendering/processing doesn't have to.

From a quick look at that package, I wouldn't suggest using it.. the resulting compressed file is 23MB+ when the actual trunk uncompressed is only less than 11MB. To get setup with an anonymous SVN checkout, follow these instructions: https://sourceforge.net/scm/?type=svn&group_id=208735

Finally, your actual problem.. it still looks like it was the thing that was patched a few days ago because line 757 in the latest ui.class.php - http://web2project.svn.sourceforge.net/viewvc/web2project/trunk/classes/ui.class.php?revision=1136&view=markup - does not include "loadObject". I think a clean checkout will get you straightened out.

~0000976

opto (manager)

thanks - works fine now.

Should I put the 'svn how to' into the wiki? (That's where I searched but didn't find anything) - together with a warning: do only use if you know what you do?

~0000978

caseydk (administrator)

That would be great.

~0000979

caseydk (administrator)

Resolved and stuff.
+Notes

-Issue History
Date Modified Username Field Change
2010-06-05 11:39 opto New Issue
2010-06-05 12:24 opto Note Added: 0000962
2010-06-05 21:09 caseydk Note Added: 0000966
2010-06-05 21:09 caseydk Status new => resolved
2010-06-05 21:09 caseydk Resolution open => fixed
2010-06-05 21:09 caseydk Assigned To => caseydk
2010-06-06 01:23 opto Note Added: 0000970
2010-06-06 01:23 opto Status resolved => feedback
2010-06-06 01:23 opto Resolution fixed => reopened
2010-06-06 01:25 opto Note Edited: 0000970
2010-06-06 07:34 caseydk Note Added: 0000971
2010-06-06 12:59 opto Note Added: 0000976
2010-06-06 17:20 caseydk Note Added: 0000978
2010-06-06 17:20 caseydk Note Added: 0000979
2010-06-06 17:20 caseydk Status feedback => resolved
2010-06-06 17:20 caseydk Resolution reopened => fixed
2010-06-06 17:21 caseydk Relationship added related to 0000466
2010-06-21 21:08 caseydk Status resolved => closed
2010-06-21 21:08 caseydk Fixed in Version => v2.0
+Issue History