Anonymous Login
2019-09-22 20:15 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000469v4.0 Release (Planning)Taskspublic2016-12-29 10:16
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusacknowledgedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0000469: display user related priority in todo and today
Descriptionsolution see attachments in http://web2project.net/forums/viewtopic.php?p=5618#5618
TagsNo tags attached.
Attached Files

-Relationships
child of 0001351acknowledgedcaseydk Customizing Task columns does not work properly 
+Relationships

-Notes

~0001250

caseydk (administrator)

I've explored this one.. it's both easy and hard:

First, it's easy to include the field in the query. Therefore, it can be accessible later as necessary.

Unfortunately, it's hard because the showtask function renders the task list on the Todo page.. and on every other page that has a task list. So we'll need to update *all* of the Task tables throughout the system.

~0001257

opto (manager)

no... not quite

because showtasks has (had in last version) an if especially for display of the todo page.

so this is independent from other task pages. Actually, I did that in 1.3 and posted all changes somewhere in a post
(added an extra column to the right of all others, changed the query, displayed the priority as interger number

~0003250

caseydk (administrator)

The todo/today view has been updated in v3.2 development to include not just the user priority but also the entire flexifield functionality:
https://github.com/web2project/web2project/commit/aa1230a2a59964bfd9bce7b4cdd48a1fbf6f29b0

~0003559

caseydk (administrator)

Resolved on master development as of here:
https://github.com/web2project/web2project/commit/c650cc4a4baf649634dde7421444838b1aadd7b7

~0003845

caseydk (administrator)


I'm changing this issue to acknowledged.

While it's resolved in the v4.0 development branch. That is going to be reviewed commit by commit and merged into a new development branch over the next couple months.
+Notes

-Issue History
Date Modified Username Field Change
2010-06-07 12:58 opto New Issue
2010-06-07 14:08 caseydk Project v2.0 Release (Closed) => Pending Requests
2010-06-11 06:05 caseydk Project Pending Requests => v2.1 Release (Closed)
2010-09-04 23:40 caseydk Note Added: 0001250
2010-09-06 11:43 opto Note Added: 0001257
2010-09-07 14:19 caseydk Project v2.1 Release (Closed) => Pending Requests
2013-03-02 23:20 caseydk Project Pending Requests => v3.1 Release
2013-12-03 21:17 caseydk Project v3.1 Release => v3.2 Release
2014-01-21 17:58 caseydk Target Version => 3.2
2014-01-25 00:46 caseydk Category General => Tasks
2014-03-02 22:14 caseydk Note Added: 0003250
2014-03-13 22:12 caseydk Relationship added child of 0001351
2014-03-27 09:44 caseydk Project v3.2 Release => v4.0 Release (Planning)
2014-06-10 22:49 caseydk Target Version 3.2 => 4.0
2014-08-01 21:46 caseydk Note Added: 0003559
2014-08-01 21:46 caseydk Status new => resolved
2014-08-01 21:46 caseydk Fixed in Version => 4.0
2014-08-01 21:46 caseydk Resolution open => fixed
2014-08-01 21:46 caseydk Assigned To => caseydk
2016-12-29 10:16 caseydk Status resolved => acknowledged
2016-12-29 10:16 caseydk Note Added: 0003845
+Issue History