Anonymous Login
2019-02-22 13:09 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000478v2.0 Release (Closed)[All Projects] Generalpublic2010-06-21 21:07
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Versionv2.0.0 
Target VersionFixed in Versionv2.0.0 
Summary0000478: projectdesigner does not 'forward' error messages
DescriptionIn bulk task changes with projectdesigner, messages on errors of single tasks are not displayed.

Example: set 33 tasks to 100% where 3 tasks can not be set by projectdesigner due to error elsewhere (in this case because enddate (not set, 00000) < startdate).

No error message is given (should be like: task id 30, 77, 102 could not be set).
So everyone would assume the bulk operation went successful, if the tasks are not manually checked after the bulk operation
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001001

caseydk (administrator)

Resolved in r1178.

It will stop at the first error it hits and return.. I considered having it try all the updates and just returning the entire set but then your Tasks could get into an odd/unstable state with updates 0000001, 2, and 4 applied but 0000003 ends up getting skipped. It might be worth figuring out a way to "test" all the changes before applying any of them.. like SVN.
+Notes

-Issue History
Date Modified Username Field Change
2010-06-12 08:36 opto New Issue
2010-06-12 11:17 caseydk Note Added: 0001001
2010-06-12 11:17 caseydk Status new => resolved
2010-06-12 11:17 caseydk Resolution open => fixed
2010-06-12 11:17 caseydk Assigned To => caseydk
2010-06-21 21:07 caseydk Status resolved => closed
2010-06-21 21:07 caseydk Fixed in Version => v2.0
+Issue History