2017-11-20 05:20 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000486v2.0 Release (Closed)[All Projects] Generalpublic2010-06-21 21:05
Reporterdavid 
Assigned Tocaseydk 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Product Versionv2.0.0 
Target VersionFixed in Versionv2.0.0 
Summary0000486: Cannot add tasks to projects
DescriptionSuccessfully installed June 8 nightly.
Created a project.
Attempted to create a task, task is not added.
Navigating back to the project, drilldown button saying that there is a multi-project structure (even though I had only created a single project), and opening the drilldown throws a php error.
Screenshots attached.
Tried with a second project, same problem.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001008

caseydk (administrator)

I can't reproduce this one on galleon, Firefox (Ubuntu or Win7), or IE8..

What version of IE are you using? Are you using any popup blockers?

~0001012

david (reporter)

IE8.0.6001, pop-up blocker off.

I just downloaded the most recent w2p nightly, configured it with a new db schema, and still cannot add tasks.

I will add the database file, in case that would help diagnose the problem.

~0001017

caseydk (administrator)

Are you getting any sort of error messages whatsoever? Javascript? PHP error log? Apache? Has it ever worked for you? Have previous versions worked for you?

~0001019

david (reporter)

The only error that appeared in the browser was the seemingly unrelated error about the project being part of a multi-project structure -- even though it was not part of a multi-project structure:
"Warning: Invalid argument supplied foreach() in C:\Program Files\Apache Software Foundation\Apache 2.2\htdocs\web2project\modules\vw_sub+projects.php on line 31"

I checked the Apache error.log, and there is no error.

I checked the database, and there was no task added.

I'm turning php error log on now.

I have never been able to add a task.

~0001021

david (reporter)

I turned on PHP logging, and no errors were logged while trying to create and save a task. Adding tasks works neither in the classic interface nor in the project designer.

~0001023

caseydk (administrator)

Is the path really described this?

C:\Program Files\Apache Software Foundation\Apache 2.2\htdocs\web2project\modules\vw_sub+projects.php

There shouldn't be a + sign in there.. and even more importantly, the path is completely wrong as there should be a module name in there. It should look something like this:

C:\Program Files\Apache Software Foundation\Apache 2.2\htdocs\web2project\modules\projects\vw_sub_projects.php

~0001027

david (reporter)

Take a look at the screenshot that I attached when I reported the bug - the error is shown in both the top and bottom panes of that file, right where the drill-down to show a project as being part of a multi-project structure.

~0001029

david (reporter)

If you would be interested, I could demonstrate the problem using gotomeeting?

~0001031

caseydk (administrator)

Ah thanks. Sure. I'm east coast US-based, so if you have time this afternoon or late this evening, I'd love to see the problem.

Otherwise, since no one else is running into the problem, this will have to be closed.

~0001034

david (reporter)

Excellent, I'm ready whenever you are - I'm on the East Coast as well.

~0001053

caseydk (administrator)

Resolved in r1187 - http://web2project.svn.sourceforge.net/viewvc/web2project?revision=1187&view=revisio
+Notes

-Issue History
Date Modified Username Field Change
2010-06-13 06:24 david New Issue
2010-06-13 06:24 david File Added: TaskCreateFail.png
2010-06-13 16:40 caseydk Note Added: 0001008
2010-06-13 16:40 caseydk Status new => feedback
2010-06-14 07:01 david Note Added: 0001012
2010-06-14 07:02 david File Added: w2pone.zip
2010-06-14 10:51 caseydk Note Added: 0001017
2010-06-14 11:15 david Note Added: 0001019
2010-06-14 11:48 david Note Added: 0001021
2010-06-14 17:38 caseydk Note Added: 0001023
2010-06-15 02:14 david Note Added: 0001027
2010-06-15 03:01 david Note Added: 0001029
2010-06-15 05:09 caseydk Note Added: 0001031
2010-06-15 06:29 david Note Added: 0001034
2010-06-16 06:53 caseydk Note Added: 0001053
2010-06-16 06:53 caseydk Status feedback => resolved
2010-06-16 06:53 caseydk Resolution open => fixed
2010-06-16 06:53 caseydk Assigned To => caseydk
2010-06-21 21:05 caseydk Status resolved => closed
2010-06-21 21:05 caseydk Fixed in Version => v2.0
+Issue History