Anonymous Login
2019-02-21 11:48 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000510v2.4 Release (Closed)[All Projects] Generalpublic2011-08-16 23:47
Reporterlaussetdelon 
Assigned Tocaseydk 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.4 
Summary0000510: Bad concequences upgrading 1.2 to 2.0
DescriptionAfter upgrade, I set :
system_timezone_title
Timezone in User Pref
and I had to set back date format (24h format)

=> 2 problems

- displayed format is still am /pm not 24h
- all the tasks have slided 1 hour in the future (see CG74 project in screen copies)
TagsNo tags attached.
Attached Files

-Relationships
parent of 0000553closedcaseydk v2.1 Release (Closed) times mixed up 
+Relationships

-Notes

~0001129

caseydk (administrator)

What timezone is the server itself in? Does it use Europe/Paris too?

I'll check out the date formatting also.

~0001137

laussetdelon (reporter)

Yes
Europe/Paris

~0001168

caseydk (administrator)

Could you open one of the tasks, set it to the proper time, save again, and see if it stays correct?

I *think* this is related to having un-updated information going through the timezone processing..

~0001184

laussetdelon (reporter)

After upgrade

All dates are swapped +1 hour
Date format is AM/PM even if I set format to 24h

see snapshot attached :
- userconf
- system conf
- date

I tried to modify the task date after upgrade

1/ setting start date
2/ setting duration
3/ setting end date by pressing end date button

=> Start date remain as modifed but end date still swapped +1hour en mode is still AM/PM



1/

~0001201

caseydk (administrator)

I think your date formatting issue is most likely a preference issue. Did you update the "Default User Preferences" or your specific user preferences?

~0001246

laussetdelon (reporter)

I did Default User Preferences update.
Now with trunk 1330, i don't have AM/PM issue anymore but still remain the start / end time moved 1 hour further.

See attached files
before : W2P in 1.2
after : W2P updated to trunk 1330

I don't know if it could help but, when I update Default User Préferences during upgrade, I need to upgrade Time Zone twice to make it taken into acount

~0001260

laussetdelon (reporter)

In fact, if I want to keep my proprer start/end time i need to set London instead of paris (where I am really is)
I noticed then an other problem that i'll describe in an other ticket.

~0001875

caseydk (administrator)

It looks like this one was resolved along the way.. not sure of the specific commit that did it. I've tested with a variety of timezone combinations and they all work out so far until v2.3..
+Notes

-Issue History
Date Modified Username Field Change
2010-07-09 03:40 laussetdelon New Issue
2010-07-09 03:40 laussetdelon File Added: TimeZoneSystem.jpg
2010-07-09 03:41 laussetdelon File Added: TimeZoneUserPref.jpg
2010-07-09 03:41 laussetdelon File Added: BerforeUpgradeTasks.jpg
2010-07-09 03:41 laussetdelon File Added: TranslatedTaskTime.jpg
2010-07-09 05:56 caseydk Note Added: 0001129
2010-07-19 02:19 laussetdelon Note Added: 0001137
2010-07-31 22:10 caseydk Priority normal => high
2010-08-02 21:37 caseydk Note Added: 0001168
2010-08-02 21:37 caseydk Status new => feedback
2010-08-06 01:32 laussetdelon File Added: userconf.jpg
2010-08-06 01:36 laussetdelon Note Added: 0001184
2010-08-06 01:36 laussetdelon File Added: systemconf.jpg
2010-08-06 01:37 laussetdelon File Added: dates.jpg
2010-08-13 23:09 caseydk Note Added: 0001201
2010-08-13 23:09 caseydk Project v2.0 Release (Closed) => v2.1 Release (Closed)
2010-08-22 15:37 caseydk Relationship added parent of 0000553
2010-09-02 05:32 laussetdelon Note Added: 0001246
2010-09-02 05:32 laussetdelon File Added: before.jpg
2010-09-02 05:32 laussetdelon File Added: after.jpg
2010-09-07 14:19 caseydk Project v2.1 Release (Closed) => Pending Requests
2010-09-09 03:28 laussetdelon Note Added: 0001260
2011-04-26 20:23 caseydk Project Pending Requests => v2.4 Release (Closed)
2011-04-26 20:27 caseydk Note Added: 0001875
2011-04-26 20:27 caseydk Status feedback => resolved
2011-04-26 20:27 caseydk Resolution open => fixed
2011-04-26 20:27 caseydk Assigned To => caseydk
2011-08-16 23:47 caseydk Status resolved => closed
2011-08-16 23:47 caseydk Fixed in Version => 2.4
+Issue History