Anonymous Login
2019-04-18 03:42 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000513v2.1 Release (Closed)[All Projects] Generalpublic2010-09-21 22:49
Reportertrevormorse 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Product Versionv2.1 
Target VersionFixed in Versionv2.1 
Summary0000513: Viewing System Admin causes php error
DescriptionWhen I view the System Admin section I only get a partial page load. See attached image for screenshot.
Additional InformationFrom my php error log:

[16-Jul-2010 01:39:48] PHP Fatal error: Uncaught exception 'Exception' with message 'DateTimeZone::__construct(): Unknown or bad timezone ()' in /home/trevor/source/web2project/modules/system/index.php:41
Stack trace:
#0 /home/trevor/source/web2project/modules/system/index.php(41): DateTimeZone->__construct('')
0000001 /home/trevor/source/web2project/index.php(363): require('/home/trevor/so...')
0000002 {main}
  thrown in /home/trevor/source/web2project/modules/system/index.php on line 41

I have double checked and my php.ini does have:

date.timezone = "America/Halifax"
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001131

trevormorse (manager)

If I update line 39 in modules/system/index.php from:
$tzName = w2PgetConfig('system_timezone');
to:
$tzName = w2PgetConfig('system_timezone', 'Europe/London');

The error in my php logs disappears, but I still get the same partial page load.

~0001132

trevormorse (manager)

This was due to the fact that I did not have a timezone set in w2p, but had date.timezone set in my php.ini file.

Fix is here - http://github.com/trevormorse/web2project/commit/ab14f7f1ccd39b0f8fdda4996a7719d16c6e6d84
+Notes

-Issue History
Date Modified Username Field Change
2010-07-15 16:58 trevormorse New Issue
2010-07-15 16:58 trevormorse File Added: web2project_system_admin.png
2010-07-15 17:08 trevormorse Note Added: 0001131
2010-07-15 17:22 trevormorse Note Added: 0001132
2010-07-15 17:22 trevormorse Assigned To => trevormorse
2010-07-15 17:22 trevormorse Status new => resolved
2010-07-15 17:22 trevormorse Resolution open => fixed
2010-08-02 22:54 caseydk Project v2.1 Release (Closed) => v2.0 Release (Closed)
2010-08-24 14:58 caseydk Project v2.0 Release (Closed) => v2.1 Release (Closed)
2010-09-21 22:11 caseydk Status resolved => closed
2010-09-21 22:33 caseydk Assigned To trevormorse =>
2010-09-21 22:33 caseydk Status closed => feedback
2010-09-21 22:33 caseydk Resolution fixed => reopened
2010-09-21 22:34 caseydk Status feedback => closed
2010-09-21 22:34 caseydk Product Version => v2.1
2010-09-21 22:39 caseydk Status closed => resolved
2010-09-21 22:49 caseydk Status resolved => closed
2010-09-21 22:49 caseydk Resolution reopened => fixed
2010-09-21 22:49 caseydk Fixed in Version => v2.1
+Issue History