2018-02-25 03:17 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000529v2.1 Release (Closed)[All Projects] Generalpublic2010-09-21 23:02
Reporterboomtonic 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Versionv2.1 
Target VersionFixed in Versionv2.1 
Summary0000529: End dates do not calculate correctly using custom TaskDurationType system lookup value
DescriptionI added two custom TaskDurationType system values for "weeks" (value = 168) and "months" (value = 730). I have verified that both values have been added to the sysvals table.

When I try to use these values to calculate and end date of a task, the end date is calculated based on hours, not weeks or months. Conversely, if I type a start and end date and then calculate a duration, the value is reported correctly for weeks or months.
Additional InformationThese values are based on an assumption that the core value is calculated in hours, since the "days" value = 24.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001173

caseydk (administrator)

I *suspect* that there are some things hardcoded behind the scenes on this one.. I'll check into it.

~0001195

caseydk (administrator)

I'm moving this one to v2.1 for next month because although it's annoying, the workaround is easy (specify durations in days).

~0001266

caseydk (administrator)

Implemented in r1457, will be in the v2.1 release
+Notes

-Issue History
Date Modified Username Field Change
2010-08-03 04:56 boomtonic New Issue
2010-08-03 06:27 caseydk Note Added: 0001173
2010-08-12 23:03 caseydk Note Added: 0001195
2010-08-12 23:03 caseydk Project v2.0 Release (Closed) => v2.1 Release (Closed)
2010-09-11 22:12 caseydk Note Added: 0001266
2010-09-11 22:12 caseydk Status new => resolved
2010-09-11 22:12 caseydk Resolution open => fixed
2010-09-11 22:12 caseydk Assigned To => caseydk
2010-09-21 22:11 caseydk Status resolved => closed
2010-09-21 22:39 caseydk Status closed => resolved
2010-09-21 22:47 caseydk Status resolved => closed
2010-09-21 22:47 caseydk Fixed in Version => v2.1
2010-09-21 23:02 caseydk Product Version v2.0.0 => v2.1
+Issue History