Anonymous Login
2019-10-20 19:35 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000533v2.1 Release (Closed)[All Projects] Generalpublic2010-09-21 23:03
Reporteropto 
Assigned Totrevormorse 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Versionv2.1 
Target VersionFixed in Versionv2.1 
Summary0000533: new link button in tasks (everywhere?) should preset project and task ID's
Descriptionthe new link button in tasks should preset project and task:

currently. the url generated is ...&project_id=&task_id=ID

project id should be inserted.

It seems that the addedit link page does not use the two GET's (by manually inserting ID's: nothing is preselected)
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001213

caseydk (administrator)

Any chance you could write a quick patch for this one?

~0001216

opto (manager)

will try.
But I 'll be on a business trip - either tomorrow or Friday in the train, or after 2.1 (?).

Klaus

~0001217

caseydk (administrator)

Excellent.

And the sooner, the better. 2.1 is still a couple weeks away.

~0001236

opto (manager)

Last edited: 2010-08-28 09:27

to get the project id (at the moment not part of get):

add global $project_id in
global $AppUI, $m, $obj, $task_id, $project_id;

in task_tab.view.links.php


in links: addedit:

get id's (at top of file)

if ($link_id==0) //we have an add, no edit
{
  $link_project= (int) w2PgetParam($_GET, 'project_id', 0);
  $link_task= (int) w2PgetParam($_GET, 'task_id', 0);
}

preset values if no link_id given
put somewhere below
// load the record data
$link = new CLink();


if ($link_id==0)
{
  $link->link_project=$link_project;
  $link->link_task = $link_task;
  $linkTask= new CTask;
  $linkTask->loadFull($AppUI, (int)1);//$link_task);
  $link->task_name=$linkTask->task_name;
}

works in IE8

any more efficient way to get just the name rather than loadFull?

I don't understand:
in \links\index_table.php:
the link button seems to be a post:
        '<form action="?m=links&a=addedit&project_id='.$project_id.'&task_id='.$task_id.'" method="post" accept-charset="utf-8">', '</form>'


but the resulting page in IE8 and the handling in addedit is a get

~0001259

trevormorse (manager)

Last edited: 2010-09-08 15:17

Hi Klaus,

Thanks for the patch, was very helpful!

I have fixed this bug in my github branch. Should hopefully be in subversion soon and will definitely be in for 2.1.

As a side note, fixing this bug caused a new one for me - http://bugs.web2project.net/view.php?id=570. Just a heads up. :-)

+Notes

-Issue History
Date Modified Username Field Change
2010-08-03 12:46 opto New Issue
2010-08-03 14:12 caseydk Project Pending Requests => v2.1 Release (Closed)
2010-08-20 21:12 caseydk Note Added: 0001213
2010-08-22 04:15 opto Note Added: 0001216
2010-08-22 10:01 caseydk Note Added: 0001217
2010-08-28 09:25 opto Note Added: 0001236
2010-08-28 09:27 opto Note Edited: 0001236
2010-09-04 23:20 caseydk Status new => assigned
2010-09-04 23:20 caseydk Assigned To => caseydk
2010-09-08 15:17 trevormorse Note Added: 0001259
2010-09-08 15:17 trevormorse Note Edited: 0001259
2010-09-08 15:19 trevormorse Assigned To caseydk => trevormorse
2010-09-08 15:19 trevormorse Status assigned => resolved
2010-09-08 15:19 trevormorse Resolution open => fixed
2010-09-21 22:11 caseydk Status resolved => closed
2010-09-21 22:39 caseydk Status closed => resolved
2010-09-21 22:47 caseydk Status resolved => closed
2010-09-21 22:47 caseydk Fixed in Version => v2.1
2010-09-21 23:03 caseydk Product Version => v2.1
+Issue History