Anonymous Login
2019-02-23 05:53 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000535v2.1 Release (Closed)[All Projects] Generalpublic2010-09-21 22:47
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
Product Versionv2.1 
Target VersionFixed in Versionv2.1 
Summary0000535: URL handling
Descriptionwww.web2project.net is resolved as //server/web2projectdirname/www.web2project.net, i.e., global URL's are not recognised
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001177

caseydk (administrator)

You have to put in the http for url's.

~0001179

opto (manager)

Last edited: 2010-08-04 08:41

so make it a feature request:

 to enter http// is ok for exotic protocols, but plain old www. should be recognised without the extra typing of http. Reduces the amount of typing necessary, and makes it easier to use for non IT people (my secretary wouldn"t know the difference)

~0001187

caseydk (administrator)

This one actually got a *lot* more complicated as we found out that many users use internal urls like: http://servername/appname Unfortunately, while this is a valid network resource, it's not a valid URL. I think we're going to have to kill URL validation for now.

~0001189

opto (manager)

there is something else:

in the code, there is a function which splits URL's into subparts and also adds http:// to all without.
But due to a parameter call by value ($link) instead of by reference (&$link), this is never actually applied.

Saw iit a few days ago, forgot function name, but can look it up if needed.

~0001190

opto (manager)

nevertheless, if the code adds http:// to all www. without, that would be a great help for non IT users.
If the link starts with 'www.', I think it is safe to assume that it is on the web.

~0001208

opto (manager)

actually, w2p_textarea has a preg_replace that does it
Could that be used for the links view?

~0001234

caseydk (administrator)

Resolved in r1326
I tweaked it so that in the store() method, if no colon and no '//' are found, it prefixes the link_url field with 'http://'

This should allow someone to do a network path:
//servername/path

or a ftp site:
ftp://keithisawesome.com

or even svn:
svn://yourhairisfunny.com

or a boring url:
myboringurl.com

and each should pass through without modification except the url which will get the prefix.

~0001287

caseydk (administrator)

test
+Notes

-Issue History
Date Modified Username Field Change
2010-08-03 12:54 opto New Issue
2010-08-03 14:10 caseydk Note Added: 0001177
2010-08-03 14:10 caseydk Status new => feedback
2010-08-03 22:13 opto Note Added: 0001179
2010-08-04 03:30 caseydk Severity major => feature
2010-08-04 08:39 opto Note Edited: 0001179
2010-08-04 08:39 opto Note Edited: 0001179
2010-08-04 08:41 opto Note Edited: 0001179
2010-08-04 08:41 opto Note Edited: 0001179
2010-08-12 12:16 caseydk Note Added: 0001187
2010-08-12 12:35 opto Note Added: 0001189
2010-08-12 12:37 opto Note Added: 0001190
2010-08-15 03:49 opto Note Added: 0001208
2010-08-20 23:56 caseydk Status feedback => assigned
2010-08-20 23:56 caseydk Assigned To => caseydk
2010-08-20 23:56 caseydk Project Pending Requests => v2.1 Release (Closed)
2010-08-24 23:44 caseydk Note Added: 0001234
2010-08-24 23:44 caseydk Status assigned => resolved
2010-08-24 23:44 caseydk Resolution open => fixed
2010-09-21 22:11 caseydk Status resolved => closed
2010-09-21 22:35 caseydk Product Version => v2.1
2010-09-21 22:37 caseydk Note Added: 0001287
2010-09-21 22:37 caseydk Status closed => feedback
2010-09-21 22:37 caseydk Resolution fixed => reopened
2010-09-21 22:37 caseydk Status feedback => closed
2010-09-21 22:37 caseydk Resolution reopened => fixed
2010-09-21 22:37 caseydk Fixed in Version => v2.1
2010-09-21 22:39 caseydk Status closed => resolved
2010-09-21 22:47 caseydk Status resolved => closed
+Issue History