2018-07-21 23:49 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000554v2.1 Release (Closed)[All Projects] Generalpublic2010-09-21 22:44
Reporterflexjoly 
Assigned Topedroa 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Versionv2.1 
Target VersionFixed in Versionv2.1 
Summary0000554: project and assigning to an event not working wel anymore
DescriptionWhen adding/changing an event:
- the chosen project is not shown in the form anymore (after saved and shown when viewing the details)
- assigned persons are not saved
- after saving an errormessage seems to be shown, but it only says: '1'
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0000561closedpedroa Attendees failing to add to Events 
+Relationships

-Notes

~0001212

opto (manager)

same at my site

~0001239

pedroa (administrator)

Fixed on SVN
Files are:
modules/calendar/addedit.php
modules/calendar/calendar.class.php

1) The chosen project was not being shown because it was expecting it as a _GET parameter, which only makes sense when asking to add a new event from a project context
2) Assigned persons were not being stored because the store method was returning the "1" error message, which in fact was a success message, but the logic of do_aed is to treat any returning messages as errors, so "1" though being a success (true), meant an error for the do_aed and stoped the process before the assignees were stored and notified.

Cheers,

Pedro A.
+Notes

-Issue History
Date Modified Username Field Change
2010-08-19 13:48 flexjoly New Issue
2010-08-20 12:47 opto Note Added: 0001212
2010-08-28 19:04 pedroa Note Added: 0001239
2010-08-28 19:04 pedroa Status new => resolved
2010-08-28 19:04 pedroa Resolution open => fixed
2010-08-28 19:04 pedroa Assigned To => pedroa
2010-08-28 19:06 pedroa Relationship added has duplicate 0000561
2010-09-21 22:11 caseydk Status resolved => closed
2010-09-21 22:35 caseydk Product Version => v2.1
2010-09-21 22:39 caseydk Status closed => resolved
2010-09-21 22:44 caseydk Status resolved => closed
2010-09-21 22:44 caseydk Fixed in Version => v2.1
+Issue History