Anonymous Login
2019-06-16 20:04 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000556v2.2 Release (Closed)[All Projects] Generalpublic2010-12-19 13:23
Reporterscarey_man 
Assigned Tocaseydk 
PrioritylowSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.2 
Summary0000556: Cant update child tasks
DescriptionHave created a project and added tasks.
Have then added child tasks to one of the main tasks.
Any subsequent changes I make to the child task are not saved.

Can modify parent tasks successfully.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001225

scarey_man (reporter)

Have also tested this on the demo site by creating a task, then child task.
Child task changes not saved.

~0001226

caseydk (administrator)

What browser? What version of web2project?

~0001227

scarey_man (reporter)

Using Firefox 3.6.8.

web2project 2.0

But also doesn't work on demo site.

~0001228

caseydk (administrator)

I just tried the demo site and it worked. I created one task, created a child with a duration of 10 hours and saved. I came back and changed the duration to 20 hours and saved. It worked as expected.

Are you getting any error messages at all? JavaScript? Application? Can you submit it?

~0001229

scarey_man (reporter)

OK, it appears as if it happens as follows:
Create task ABCD. Save.

Create child task XYZ with parent ABCD.
Ensure child task has a task dependency of ABCD, with tracking on. Save.

After this, any changes to the child task are not saved until the task dependency to the parent task is removed.
Other task dependencies are fine, seems only to be an issue if Parent Task and Task Dependency are the same.
Thinking about it, no point in having a task dependency being the same as the parent, but would hope to have a popup or something saying so.

~0001230

caseydk (administrator)

You're right that it shouldn't be possible having a parent as a dependency and realistically the system should notify you and so this is a pretty odd/exceptional case.

Therefore, I'm going to lower the priority and make it pending review for a future release.

~0001406

caseydk (administrator)

Removed the option to have a parent as a dependency.. did it via the backend (post-save) since we don't necessarily know which parent is selected on the front end and therefore don't know which tasks to disallow from the dependency box.

Resolved in r1519, will be in the v2.2 release.

~0001463

caseydk (administrator)

In v2.2 release.
+Notes

-Issue History
Date Modified Username Field Change
2010-08-24 02:16 scarey_man New Issue
2010-08-24 02:20 scarey_man Note Added: 0001225
2010-08-24 05:54 caseydk Note Added: 0001226
2010-08-24 05:56 scarey_man Note Added: 0001227
2010-08-24 07:45 caseydk Note Added: 0001228
2010-08-24 07:50 scarey_man Note Added: 0001229
2010-08-24 22:26 caseydk Note Added: 0001230
2010-08-24 22:26 caseydk Project v2.0 Release (Closed) => Pending Requests
2010-08-24 22:27 caseydk Priority normal => low
2010-08-24 22:27 caseydk Severity major => block
2010-08-24 22:27 caseydk Status new => acknowledged
2010-12-06 22:36 caseydk Project Pending Requests => v2.2 Release (Closed)
2010-12-06 22:38 caseydk Note Added: 0001406
2010-12-06 22:38 caseydk Status acknowledged => resolved
2010-12-06 22:38 caseydk Resolution open => fixed
2010-12-06 22:38 caseydk Assigned To => caseydk
2010-12-19 13:23 caseydk Note Added: 0001463
2010-12-19 13:23 caseydk Status resolved => closed
2010-12-19 13:23 caseydk Fixed in Version => 2.2
+Issue History