2018-02-25 03:19 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000565v2.1 Release (Closed)[All Projects] Generalpublic2010-09-21 23:07
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
Product Versionv2.1 
Target VersionFixed in Versionv2.1 
Summary0000565: showtask does not display priority if sysval is set to more than -1 0 +1
Descriptionactually, the tag showing the image needs an alt to display the text (prio number) if no image present

 
in <img src= etc alt= $arr['task_priority'] />

(at the moment, my concentration is too low to get all these ' and " correct for it to display correct)

    if ($arr['task_priority'] < 0) {
        $s .= '<img src="' . w2PfindImage('icons/priority-' . -$arr['task_priority'] . '.gif') . '" />';
    } elseif ($arr['task_priority'] > 0) {
        $s .= '<img src="' . w2PfindImage('icons/priority+' . $arr['task_priority'] . '.gif') . '" />';
    }
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001243

opto (manager)

well, +-2 is also displayed as icon.

for higher, the following helps partly:
        $s .= '<img src="' . w2PfindImage('icons/priority-' . -$arr['task_priority'] . '.gif') . '" alt="'.$arr['task_priority']. '"/>';
    } elseif ($arr['task_priority'] > 0) {
        $s .= '<img src="' . w2PfindImage('icons/priority+' . $arr['task_priority'] . '.gif') . '" alt="'.$arr['task_priority']. '" />';


in todo, gives red cross and priority number .. not nice, but better than nothing (which implies prio==0)

in user related task screen, seems the field is to narrow to display, so there is an empty white box (in IE)

~0001281

opto (manager)

Interesting, this time no note screen came up on first try (just reassigning at current status).

Anyway, the second note gives a workaround that is better than just ignoring priorities above 2. Could go into core and leave bug open for better solution sometime later.

As said above, solves tasklist but not user rel priorities, because the column is too narrow to display cross for missing grafic and the alt text.
Klaus
+Notes

-Issue History
Date Modified Username Field Change
2010-08-29 10:10 opto New Issue
2010-08-29 12:19 opto Note Added: 0001243
2010-08-30 22:13 caseydk Project v2.0 Release (Closed) => v2.1 Release (Closed)
2010-09-07 14:19 caseydk Project v2.1 Release (Closed) => Pending Requests
2010-09-19 10:28 opto Status new => assigned
2010-09-19 10:28 opto Assigned To => caseydk
2010-09-19 10:32 opto Note Added: 0001281
2010-09-19 10:32 opto Status assigned => resolved
2010-09-19 10:32 opto Resolution open => fixed
2010-09-19 22:34 caseydk Project Pending Requests => v2.2 Release (Closed)
2010-09-21 22:08 caseydk Project v2.2 Release (Closed) => v2.1 Release (Closed)
2010-09-21 22:11 caseydk Status resolved => closed
2010-09-21 22:39 caseydk Status closed => resolved
2010-09-21 22:42 caseydk Status resolved => closed
2010-09-21 22:42 caseydk Fixed in Version => v2.1
2010-09-21 23:07 caseydk Product Version => v2.1
+Issue History