Anonymous Login
2019-05-27 02:50 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000567v2.1 Release (Closed)[All Projects] Generalpublic2010-09-21 22:42
Reporterpaul_rogers6 
Assigned Topedroa 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Versionv2.1 
Target VersionFixed in Versionv2.1 
Summary0000567: Email Notification not working when uploading/editing files
DescriptionWhen a new file is uploaded (with both project and task set) and the notify project owner/assignees tick box is ticked no email notification is received by either the project owner or the assignee of the task
Additional InformationIn tested scenario I was set to both Project Owner and assignee of task. See this thread:

http://forums.web2project.net/viewtopic.php?t=2506

Amy suggests assignne notification is working for her but I can't make it work.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001263

pedroa (administrator)

Fixed on SVN

File is modules/files/files.class.php

Please read the commit message:

"Fixed email notification for files.
Bear in mind that notifications will only be sent to:
Assignees or (if they don't exist) to the project owner.
Besides that also project contacts will bee notified.
Last but not least, if you are an assignee or (if those don't exist) the project owner, and you are doing the file upload then you are not going to get an email, because we presume that you don't need to be notified of what you are doing, or just done.

Also fixed the editing of Files if no file is to sent on the edit process, and you only want to "touch" the file info details.
If no file is being uploaded then we don't need to index the file, because there is nothing new to index anyway.
(As a matter of fact this would lead to an error because we have no access to the temp file for index when editing anymore)
"

Thanks for reporting,

Pedro A.
+Notes

-Issue History
Date Modified Username Field Change
2010-08-30 02:58 paul_rogers6 New Issue
2010-08-30 22:13 caseydk Project v2.0 Release (Closed) => v2.1 Release (Closed)
2010-09-10 08:33 pedroa Note Added: 0001263
2010-09-10 08:33 pedroa Status new => resolved
2010-09-10 08:33 pedroa Resolution open => fixed
2010-09-10 08:33 pedroa Assigned To => pedroa
2010-09-21 22:11 caseydk Status resolved => closed
2010-09-21 22:30 caseydk Product Version v2.0.0 => v2.1
2010-09-21 22:39 caseydk Status closed => resolved
2010-09-21 22:42 caseydk Status resolved => closed
2010-09-21 22:42 caseydk Fixed in Version => v2.1
+Issue History