Anonymous Login
2019-10-20 21:47 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000595v2.3 Release (Closed)[All Projects] Generalpublic2011-03-24 09:52
Reporterpeter 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.3 
Summary0000595: During installation no check if database parameters are invalid
DescriptionDuring my migration / installation of web2project I found an issue regarding database parameters. If incorrect database parameters are provided the setup script will only detect that the dotProject version could not be determined. And installation CAN continue. IMHO that's wrong

Steps to reproduce:
1. Provide a dotproject config.php with incorrect password
2. Browse to index.php and see that installation check will start
3. In the results see that the dotProject version could not be determined
4. If you continue installation the database is not migrated and web2project doesn't work

Suggested fix:
In step 3, if it is clear that a database connection could not be established, make that clear by stating for example: "A database connection could not be established, please check the parameters". And make it impossible to continue installation if there is no valid database connection.
Additional InformationThe reason that the password was not valid is because I had to do a migration from mysql4 to mysql5.
TagsNo tags attached.
Attached Files
  • diff file icon patch595.diff (746 bytes) 1969-12-31 16:00 -
    Index: check.php
    ===================================================================
    --- check.php	(revision 1475)
    +++ check.php	(working copy)
    @@ -64,6 +64,19 @@
     		</td>
     	</tr>
     	<tr>
    +		<td class="item">Database connection</td>
    +		<td align="left">
    +		<?php
    +			if (!$manager->testDatabaseCredentials($manager->getConfigOptions())) {
    +				echo '<b class="error">'.$failedImg.'</b><b class="error">Your database credentials failed.  System installation has stopped.  Please correct them and try again.</span>';
    +				$continue = false; 
    +			} else {
    +				echo '<b class="ok">'.$okImg.'</b> Succes! ';
    +			}
    +		?>
    +		</td>
    +	</tr>
    +	<tr>
     		<td class="title" colspan="2"><br />Check requirements for optional components</td>
     	</tr>
     	<tr>
    
    diff file icon patch595.diff (746 bytes) 1969-12-31 16:00 +

-Relationships
+Relationships

-Notes

~0001315

peter (reporter)

I've created a patch which will check the database connection before the conversion will start.

The patch can be applied to instal\conversion\check.php

~0001702

caseydk (administrator)

Resolved in r1710;

~0001784

caseydk (administrator)

Closed in preparation for v2.3 release.
+Notes

-Issue History
Date Modified Username Field Change
2010-10-08 01:35 peter New Issue
2010-10-20 03:35 peter Note Added: 0001315
2010-10-20 03:35 peter File Added: patch595.diff
2010-10-20 08:56 caseydk Status new => assigned
2010-10-20 08:56 caseydk Assigned To => caseydk
2010-12-28 20:41 caseydk Category -- none specified -- => Core Infrastructure
2011-01-08 10:14 caseydk Project Pending Requests => v2.3 Release (Closed)
2011-02-28 20:57 caseydk Note Added: 0001702
2011-02-28 20:57 caseydk Status assigned => resolved
2011-02-28 20:57 caseydk Resolution open => fixed
2011-03-24 09:52 caseydk Note Added: 0001784
2011-03-24 09:52 caseydk Status resolved => closed
2011-03-24 09:52 caseydk Fixed in Version => 2.3
+Issue History