Anonymous Login
2019-02-21 15:54 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000599v2.2 Release (Closed)[All Projects] Generalpublic2010-12-19 13:23
Reporterrened 
Assigned Topedroa 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.2 
Summary0000599: WHITE SCREEN
DescriptionFatal error: Call to a member function format() on a non-object in /home/pharmghi/public_html/web2project/modules/tasks/tasks.class.php on line 1050

Occurs when posting a dynamic task and edit update. Edit is recorded in database and shows correctly when using the back button of the browser.

How do I fix?
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001302

caseydk (administrator)

Looks like the task_start_date isn't getting set when it tries to send out the email notifications.. is your start date set when you save the task?

~0001303

rened (reporter)

Tried again by resetting both dates - still reports error.

~0001304

rened (reporter)

Occurs when dependencies -> dynamic task is ticked = Fatal error: Call to a member function format() on a non-object in /public_html/web2project/modules/tasks/tasks.class.php on line 1050.

If left un-ticked then works ok.

~0001324

pedroa (administrator)

Fixed on SVN

Just made sure there is an object before applying the format method.

File is modules/tasks/tasks.class.php

Revision 1482
http://web2project.svn.sourceforge.net/web2project/?rev=1482&view=rev

Pedro A.

~0001469

caseydk (administrator)

In v2.2 release.
+Notes

-Issue History
Date Modified Username Field Change
2010-10-10 09:10 rened New Issue
2010-10-10 09:33 caseydk Note Added: 0001302
2010-10-10 10:00 rened Note Added: 0001303
2010-10-10 10:04 rened Note Added: 0001304
2010-10-26 07:05 pedroa Note Added: 0001324
2010-10-26 07:05 pedroa Status new => resolved
2010-10-26 07:05 pedroa Resolution open => fixed
2010-10-26 07:05 pedroa Assigned To => pedroa
2010-11-24 23:35 caseydk Project v2.1 Release (Closed) => v2.2 Release (Closed)
2010-12-19 13:23 caseydk Note Added: 0001469
2010-12-19 13:23 caseydk Status resolved => closed
2010-12-19 13:23 caseydk Fixed in Version => 2.2
+Issue History