Anonymous Login
2019-11-19 17:12 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000605v2.2 Release (Closed)[All Projects] Generalpublic2010-12-19 13:23
Reporterdte 
Assigned Tocaseydk 
PrioritynormalSeverityblockReproducibilityhave not tried
StatusclosedResolutionduplicate 
Product Version 
Target VersionFixed in Version2.2 
Summary0000605: Denial access to a project for anyone
DescriptionAfter changing Company setting of a project, no one have access anymore to the project, neither administrator. Click on Project name leads to:

(RedIcon white cross) Access Denied
You have attempted to access an item in web2Project without the sufficient permissions to do so. Please contact the web2Project System Administrator.

My admin account has full access to all projects, and i can access other project of the same Company.

Additional InformationTrying to step back to previous Company set on the project from PhpMyAdmin ( :-( )
with no result.
TagsNo tags attached.
Attached Files

-Relationships
duplicate of 0000622closedcaseydk I can't open project which have empty field above name of department selected 
+Relationships

-Notes

~0001310

pedroa (administrator)

I tried your walk through and I can't replicate it.

I edited a project, changed the Company, and there it was on the projects list, clicked it, viewed it, edited it... no access denied error.

So there must be something more to it.

Can you paste Project record here? Can be in sql format from phpmyadmin.

Cheers,

Pedro A.

~0001312

dte (reporter)

Uploaded 2 SQL files of the project and its 2 tasks associated to.

~0001397

caseydk (administrator)

Are you using Departments at all?

If so, I found a variation of this one in 0000622. In that case, the permissions check comes up with an invalid combination of Company & Department and since they don't go together, it blocks access.

If not.. I'm stumped.

~0001436

caseydk (administrator)

Believed to be resolved as of r1509;
Pending further feedback, this is resolved;

~0001471

caseydk (administrator)

In v2.2 release.
+Notes

-Issue History
Date Modified Username Field Change
2010-10-18 05:04 dte New Issue
2010-10-19 11:13 pedroa Note Added: 0001310
2010-10-19 11:14 pedroa Status new => feedback
2010-10-19 13:13 dte File Added: tasks_TICTAC.sql
2010-10-19 13:13 dte File Added: project_TicTac.sql
2010-10-19 13:15 dte Note Added: 0001312
2010-11-24 23:35 caseydk Project v2.1 Release (Closed) => v2.2 Release (Closed)
2010-12-03 23:38 caseydk Note Added: 0001397
2010-12-14 21:39 caseydk Note Added: 0001436
2010-12-14 21:39 caseydk Relationship added duplicate of 0000622
2010-12-14 21:39 caseydk Duplicate ID 0 => 622
2010-12-14 21:39 caseydk Status feedback => resolved
2010-12-14 21:39 caseydk Resolution open => duplicate
2010-12-14 21:39 caseydk Assigned To => caseydk
2010-12-19 13:23 caseydk Note Added: 0001471
2010-12-19 13:23 caseydk Status resolved => closed
2010-12-19 13:23 caseydk Fixed in Version => 2.2
+Issue History