Anonymous Login
2019-12-10 21:23 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000615v4.0 Release (Planning)Filespublic2016-12-29 10:16
Reportermiroslaw 
Assigned Tocaseydk 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusacknowledgedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0000615: New feature for Permission Module: Files
DescriptionI can make permissions for module "Files", and on Item... I can make selection based on files.
But would it be possible to make permissions also based on folders?
For example. I have more departments. Each department have it's own folder. Maybe it would be good if I could make permission for users from department 1 to have access only to files in folder 1?

TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0000644closedcaseydk Pending Requests Separate permissions for Folders 
+Relationships

-Notes

~0003688

caseydk (administrator)

Resolved in development:
https://github.com/web2project/web2project/commit/4bbd7803ec45ceaf9025309a76ce2173200a9ce6

~0003830

caseydk (administrator)


I'm changing this issue to acknowledged.

While it's resolved in the v4.0 development branch. That is going to be reviewed commit by commit and merged into a new development branch over the next couple months.
+Notes

-Issue History
Date Modified Username Field Change
2010-10-29 07:05 miroslaw New Issue
2010-12-08 12:41 caseydk Project Pending Requests => v2.3 Release (Closed)
2011-03-08 22:15 caseydk Project v2.3 Release (Closed) => v2.4 Release (Closed)
2011-05-30 21:48 caseydk Reproducibility unable to reproduce => N/A
2011-05-30 21:49 caseydk Relationship added has duplicate 0000644
2011-06-07 22:16 caseydk Project v2.4 Release (Closed) => Pending Requests
2014-08-16 18:45 caseydk Category General => Files
2014-10-12 12:34 caseydk Project Pending Requests => v4.0 Release (Planning)
2014-10-12 12:49 caseydk Note Added: 0003688
2014-10-12 12:49 caseydk Status new => resolved
2014-10-12 12:49 caseydk Fixed in Version => 4.0
2014-10-12 12:49 caseydk Resolution open => fixed
2014-10-12 12:49 caseydk Assigned To => caseydk
2014-10-12 12:50 caseydk Target Version => 4.0
2016-12-29 10:16 caseydk Status resolved => acknowledged
2016-12-29 10:16 caseydk Note Added: 0003830
+Issue History