Anonymous Login
2019-04-24 15:37 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000622v2.2 Release (Closed)[All Projects] Generalpublic2010-12-19 13:24
Reportermiroslaw 
Assigned Tocaseydk 
PriorityurgentSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.2 
Summary0000622: I can't open project which have empty field above name of department selected
DescriptionWhen I'm creating new project, I'm choosing department. If I accidently select empty field above name of departments after closing this project I can't open it any more. Not even with admin user.

I can't open this project, I can't delete it.
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0000617closedcaseydk On changing start date : Access Denied | You have attempted to access an item in web2Project without the sufficient permissions 
has duplicate 0000605closedcaseydk Denial access to a project for anyone 
+Relationships

-Notes

~0001343

robertbasic (developer)

I tried to reproduce this issue, by the screencast provided, but couldn't. Steps I took (on a clean install):
 * admin user create company Baz, create department Bazzinga
 * admin user create user role bar, with the following permissions:
   * App: Departments - Edit - allow
   * App: Projects - Access, View, Edit, Add - allow
   * Companies: Baz - Access, View - allow
 * admin user create user Foo, which is added to company Baz and department Bazzinga
 * admin adds user role bar to user Foo

After that, logged in as Foo, created a new project Test, for company selected Test, for department selected none. Result, user Foo can access the new project Test.

Most likely I missed something, but this is all I got out from the video. If you could, please provide exact steps to reproduce this issue on a clean install.

Question: is the user eb4740 allowed only to open projects just for a department within a company? If so, then when creating a new project there shouldn't be an option to select "none" for the department.

~0001344

miroslaw (reporter)

Ok, I have simplify problema.
I have Test Company with one department.
Role:
App: Projects - Access View Add Edit - allow
Companies: TEST Company - Access View - allow
App: Departments - Access View Add Edit - allow

User have this role, nothing else.
When he creates new project, he choose Company "Test Company" and accidently select empty field above name of department.
After that he (no one else including admin) can open/edit/delete this project.

~0001392

caseydk (administrator)

When you were selecting that field, a dept_id of zero was getting stored in project_departments.. then on the permissions check, since there wasn't a match for dept_id zero, you'd be blocked from viewing the project.
Resolved in r1509, will be in v2.2 release.

You may want to run this to clean up old data:

delete FROM `project_departments` WHERE department_id = 0;

~0001479

caseydk (administrator)

In v2.2 release.
+Notes

-Issue History
Date Modified Username Field Change
2010-11-04 22:34 miroslaw New Issue
2010-11-04 22:34 miroslaw File Added: error_new_project.zip
2010-11-07 11:18 robertbasic Note Added: 0001343
2010-11-08 01:21 miroslaw Note Added: 0001344
2010-11-24 23:35 caseydk Project v2.1 Release (Closed) => v2.2 Release (Closed)
2010-11-24 23:47 caseydk Priority normal => urgent
2010-12-03 12:19 caseydk Note Added: 0001392
2010-12-03 12:19 caseydk Status new => resolved
2010-12-03 12:19 caseydk Resolution open => fixed
2010-12-03 12:19 caseydk Assigned To => caseydk
2010-12-14 21:38 caseydk Relationship added has duplicate 0000617
2010-12-14 21:39 caseydk Relationship added has duplicate 0000605
2010-12-19 13:24 caseydk Note Added: 0001479
2010-12-19 13:24 caseydk Status resolved => closed
2010-12-19 13:24 caseydk Fixed in Version => 2.2
+Issue History