Anonymous Login
2019-06-26 19:56 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000063v2.0 Release (Closed)[All Projects] Generalpublic2010-06-21 21:03
Reportercaseydk 
Assigned Tocaseydk 
PriorityimmediateSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
Product Versionv2.0.0 
Target VersionFixed in Versionv2.0.0 
Summary0000063: User-based Timezones
DescriptionEach user should be able to configure a timezone for the display/notification of their Events, Tasks, etc.

Additional InformationImplementation tip:

When a User creates an Event, Task, etc, the date information should be stored in GMT. When each User looks at an Event, Task, etc, the datetime information should be displayed according to their timezone selection.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000144

casn (reporter)

Last edited: 2008-11-17 02:52

I have done some work on that for DP, perhaps usable for W2P.
So far I had little feedback on it would require validation.
Have attached my dp stuff to this issue.

~0000836

caseydk (administrator)

I've gotten the beginning of this working start to finish. It requires a system_timezone to be set in web2project and an individual users' TZ to be set, but it works reliably.

~0001054

caseydk (administrator)

Added a bunch of this in r1189.

It was *SUPPOSED* to come in as separate commits. I'm not sure why it didn't. I need to practice my git-fu. :(

~0001055

caseydk (administrator)

The left over core modules that need updating are:

Projects
Tasks
Project Designer
Event_Queue (not a module)

~0001058

caseydk (administrator)

Implemented the updates to the Projects, Tasks, and Project Designer modules in r1190-1192.

Still needs heavy testing.

~0001059

caseydk (administrator)

One issue that I've already discovered is due to the fact that we've never used timezones previously.. it may create some screwy task/event times in the short term.

While this is a pain, I don't know of a better way to transform the times reliably since the vast majority of users seem to have put in the times relative to their own timezone and not something consistent like GMT/UTC..
+Notes

-Issue History
Date Modified Username Field Change
2008-09-06 12:03 caseydk New Issue
2008-11-17 02:51 casn File Added: DP_Timezone.zip
2008-11-17 02:51 casn Note Added: 0000144
2008-11-17 02:52 casn Note Edited: 0000144
2009-12-08 12:00 caseydk Project Pending Requests => v2.0 Release (Closed)
2010-04-26 09:58 caseydk Status new => assigned
2010-04-26 09:58 caseydk Assigned To => caseydk
2010-04-26 09:59 caseydk Note Added: 0000836
2010-06-05 21:55 caseydk Priority normal => immediate
2010-06-16 08:57 caseydk Note Added: 0001054
2010-06-16 08:57 caseydk Note Added: 0001055
2010-06-16 20:33 caseydk Note Added: 0001058
2010-06-16 20:33 caseydk Status assigned => resolved
2010-06-16 20:33 caseydk Resolution open => fixed
2010-06-16 20:39 caseydk Note Added: 0001059
2010-06-21 21:03 caseydk Status resolved => closed
2010-06-21 21:03 caseydk Fixed in Version => v2.0
2010-06-21 21:03 caseydk Product Version => v2.0
+Issue History