Anonymous Login
2019-06-24 21:07 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000632v2.3 Release (Closed)[All Projects] Generalpublic2011-03-24 09:53
ReporterArmaia 
Assigned Topedroa 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.3 
Summary0000632: Print function produces wrong charaters
DescriptionHi,

When I try to print from Project Designer it works but the portuguese characters are replaced by a anowing symbol, like showed on the attached image.
Can someone help with this?

Thanks in advance,

AM
TagsNo tags attached.
Attached Files

-Relationships
related to 0000587feedbackpedroa Pending Requests mysql can't read chinese 
parent of 0000598feedbackcaseydk Pending Requests adodb-mysql does not set default character set for db connection, this can lead in unusable database content 
Not all the children of this issue are yet resolved or closed.
+Relationships

-Notes

~0001362

caseydk (administrator)

Pedro, do you have any insight into this one? You seem to know more about character sets than me.

~0001364

pedroa (administrator)

If the browser is correctly set to UTF-8 encoding, via menu View->Encoding->UTF-8, this can happen if the data is badly encoded on the database itself.
Was the data stored through web2Project, or was it imported from dotProject?
Can you please edit any of those "weird" tasks names and see if that fixes anything.

There is another issue around here about that covers things like mysql data connection encoding, and data charset conversion data that may apply to this situation.

I have projects here with "special characters" and they show alright on that report, so it is not a strict web2project issue. It has to do with charset problems at the db level.

So there is the need to pinpoint where the encoding is being badly enforced, if on the database itself (check the tables encoding), or the database default connection encoding.

Cheers,

Pedro A.

~0001365

pedroa (administrator)

Keith,

I added relationships to:
http://bugs.web2project.net/view.php?id=587
http://bugs.web2project.net/view.php?id=598

I would appreciate your opinion about them.

They may also require Wiki attention/documentation for these sort of issues that have to do with the Data encoding and Data Connection encoding.

I am sure you will find this important for all languages that use special characters, and affect a growing number of users, as more and more non-English users are using web2Project.

Cheers,

Pedro A.

~0001366

Armaia (reporter)

Hi Pedro,

Those tasks were imported with Project Importer from a .xml file, but I added a new task with portuguese characters inside de task module on W2p and it happens the same.
In the Database the charaters are OK and the collation is utf8_general_ci.

Best Regards,

~0001367

pedroa (administrator)

So everything is alright throughout web2Project and it is only here that you are seeing weird characters?
IE encoding is set to UTF-8?

The only thing missing on this "report" is the HTML HEAD trying to force utf-8, but I tried it on a IE 8 around here and it has shown tasks created in web2Project with the correct special characters even without the HTM HEADer.

Pedro A.

~0001376

caseydk (administrator)

Pedro, thanks for the heads up and insights.

Also, if you look at index.php around line 222.. if $suppressHeaders is Off (as in the headers show), the charset gets set. Otherwise, it doesn't. Would that have an impact here?

~0001377

pedroa (administrator)

On this report suppressHeaders is On, therefore the charset does not get set on the Headers.
When I try the report here, it shows alright on IE-8.

That's the reason for my latest questions to Armaia.

I also ask Armaia, to try to change the last part of the URL directly to...
index.php?m=projectdesigner&a=printproject&dialog=1&project_id=[number id of the affected project]

And see if the characters show up alright. That would tell us if suppressHeaders has any influence on this, and therefore the utf-8 Header.

Cheers,

Pedro A.

~0001379

Armaia (reporter)

Last edited: 2010-11-26 09:49

Pedro,

If I try to print directly to the URL
http://localhost/Web2Project/index.php?m=projectdesigner&a=printproject&suppressheader=1&dialog=1&project_id=3, aparently the task names appears OK but the headers appears with wrong characters. It seems a probleming with the encoding (UTF/ISO).
I attach an image with parts of HTML parts.

Regards,

~0001380

pedroa (administrator)

Try:

http://localhost/Web2Project/index.php?m=projectdesigner&a=printproject&dialog=1&project_id=3

Instead.

The task names looked like crap to me on that last image you attached. Just like the ones on the first gif.

The <form> tag here should not exist in the first place, when we say headers we mean:
<meta http-equiv="Content-Type" content="text/html;charset=utf-8" />

Cheers,

Pedro A.

~0001382

Armaia (reporter)

Pedro,

If I access directly with:

http://localhost/Web2Project/index.phpm=projectdesigner&a=printproject&dialog=1&project_id=3 [^]

it works. The Chars are shown OK.

Regards,

~0001631

caseydk (administrator)

So is this one resolved?

~0001644

pedroa (administrator)

Thanks for the heads up Keith :)

Fixed the missing HTML headers

Thanks for reporting.
File is:
modules/projectdesigner/printproject.php

Cheers,

Pedro A.
+Notes

-Issue History
Date Modified Username Field Change
2010-11-22 08:34 Armaia New Issue
2010-11-22 08:34 Armaia File Added: Print_project_designer.gif
2010-11-24 23:35 caseydk Project v2.1 Release (Closed) => v2.2 Release (Closed)
2010-11-24 23:44 caseydk Status new => assigned
2010-11-24 23:44 caseydk Assigned To => pedroa
2010-11-24 23:45 caseydk Note Added: 0001362
2010-11-25 02:45 pedroa Note Added: 0001364
2010-11-25 02:47 pedroa Relationship added related to 0000587
2010-11-25 02:48 pedroa Relationship added parent of 0000598
2010-11-25 02:55 pedroa Note Added: 0001365
2010-11-25 03:17 Armaia Note Added: 0001366
2010-11-25 03:33 pedroa Note Added: 0001367
2010-11-26 07:55 caseydk Note Added: 0001376
2010-11-26 09:02 pedroa Note Added: 0001377
2010-11-26 09:48 Armaia Note Added: 0001379
2010-11-26 09:48 Armaia Note Edited: 0001379
2010-11-26 09:49 Armaia File Added: Image1.jpg
2010-11-26 09:49 Armaia Note Edited: 0001379
2010-11-26 10:11 pedroa Note Added: 0001380
2010-11-27 09:21 Armaia Note Added: 0001382
2010-12-15 21:54 caseydk Project v2.2 Release (Closed) => v2.3 Release (Closed)
2011-02-15 20:32 caseydk Note Added: 0001631
2011-02-17 09:46 pedroa Note Added: 0001644
2011-02-17 09:46 pedroa Status assigned => resolved
2011-02-17 09:46 pedroa Resolution open => fixed
2011-03-24 09:53 caseydk Fixed in Version => 2.3
2011-03-24 09:53 caseydk Status resolved => closed
+Issue History