Anonymous Login
2019-06-24 06:22 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000643v2.2 Release (Closed)[All Projects] Generalpublic2010-12-19 13:18
Reporterpaul_rogers6 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.2 
Summary0000643: When tasks are listed, if two tasks have the same start_date order may be incorrect.
DescriptionIf two tasks have the same task_start_date then the order which they appear in the project tasks list is not always correct. This is particularly obvious where one of the tasks is a milestone, eg:

Name task_start_date task_end_date
Order raised 23/11/2010 08:00 23/11/2010 08:00 (milestone)
Preparation 23/11/2010 08:00 27/11/2010 17:00

In the above case the preparation activity often appears before the "order raised" activity.
Additional InformationThis is because the sql in modules/tasks/tasks.php only order on the task_start_date, thus:

    311 if (!$project_id && !$task_id) {
    312 $q->addOrder('p.project_id, task_start_date');
    313 } else {
    314 $q->addOrder('task_start_date');
    315 }
(line numbers for v2.1.0 shown)

This should be changed as follows:

    311 if (!$project_id && !$task_id) {
    312 $q->addOrder('p.project_id, task_start_date, task_end_date');
    313 } else {
    314 $q->addOrder('task_start_date, task_end_date');
    315 }

An updated copy of the file is included (v2.1.0).

TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001389

caseydk (administrator)

Patched as described in r1508, will be in the v2.2 release.

~0001452

caseydk (administrator)

In v2.2 release.
+Notes

-Issue History
Date Modified Username Field Change
2010-11-25 01:06 paul_rogers6 New Issue
2010-11-25 01:06 paul_rogers6 File Added: tasks.php
2010-12-03 11:52 caseydk Project v2.0 Release (Closed) => v2.2 Release (Closed)
2010-12-03 11:53 caseydk Note Added: 0001389
2010-12-03 11:53 caseydk Status new => resolved
2010-12-03 11:53 caseydk Resolution open => fixed
2010-12-03 11:53 caseydk Assigned To => caseydk
2010-12-19 13:18 caseydk Note Added: 0001452
2010-12-19 13:18 caseydk Status resolved => closed
2010-12-19 13:18 caseydk Fixed in Version => 2.2
+Issue History