Anonymous Login
2019-02-21 16:51 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000664v2.3 Release (Closed)[All Projects] Generalpublic2011-03-24 09:53
Reportereureka 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.3 
Summary0000664: increase the module size limit for the installer
DescriptionThe file size for a module is limited to 250000 bytes, why ?

Is it possible to increase this size?

For example:
$maxsize = preg_replace(array('/\s*K/i', '/\s*M/i', '/\s*G/i'), array('000', '000000', '000000000'), ini_get("upload_max_filesize"));
if ($this->filesize > $maxsize) {
........

TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001489

caseydk (administrator)

Is it that you're hitting your upload_max_filesize or you just want it that by default?

I wouldn't necessarily set it to that.. if someone allows large files to be uploaded for the Files module, that's not a problem, but it's unlikely to have a comparably sized file for a module.

~0001492

eureka (reporter)

Last edited: 2010-12-22 23:21

This is because I am currently developing a "wiki" module and its compressed size is actually 1070ko, I can not upload it with the installer.

~0001499

caseydk (administrator)

A 1MB+ moudule? Wow. Are there lots of images or a separate framework or.. ?

I'm not criticizing, just surprised.

~0001516

eureka (reporter)

you're right, I forgot a big file in the directory module. Its real size is 435 kb.

It uses markItUp (http://markitup.jaysalvat.com/home/) for the user interface and I developed php code for parsing these wiki syntaxes: Textile, Creole, Markdown and MediaWiki

Can you, please, consider raising this limit to 500 kb?

~0001526

caseydk (administrator)

In r1571 I've increased the limit to 1000000 bytes (just less than 1 MB).
+Notes

-Issue History
Date Modified Username Field Change
2010-12-22 12:16 eureka New Issue
2010-12-22 17:41 caseydk Note Added: 0001489
2010-12-22 17:41 caseydk Status new => feedback
2010-12-22 23:20 eureka Note Added: 0001492
2010-12-22 23:21 eureka Note Edited: 0001492
2010-12-23 10:59 caseydk Note Added: 0001499
2010-12-31 00:49 eureka Note Added: 0001516
2011-01-06 21:02 caseydk Project Pending Requests => v2.3 Release (Closed)
2011-01-06 21:04 caseydk Note Added: 0001526
2011-01-06 21:04 caseydk Status feedback => resolved
2011-01-06 21:04 caseydk Resolution open => fixed
2011-01-06 21:04 caseydk Assigned To => caseydk
2011-03-24 09:53 caseydk Fixed in Version => 2.3
2011-03-24 09:53 caseydk Status resolved => closed
+Issue History