Anonymous Login
2019-11-21 13:45 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000669v4.0 Release (Planning)Core Infrastructurepublic2016-12-29 10:16
Reportereureka 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusacknowledgedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0000669: PEAR/Date
DescriptionThe method "compare" of the class "PEAR/Date" does not preserve the compared dates due to the timezone conversion. Thus, when using "compare", "equals", "before " or "after" the compared dates are not the same before and after comparison.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001517

eureka (reporter)

This bug has been fixed in release 1.5.0a1

see :http://pear.php.net/bugs/bug.php?id=12019

~0001521

trevormorse (manager)

Hi eureka,

Thanks for reporting this (and the link to the fix). I'm going to look at upgrading the version of the PEAR Date class we use.

~0001525

trevormorse (manager)

eureka, Is there anywhere in particular you are seeing this cause problems? We've had some problems in the past when attempting to upgrade the PEAR/Date class.

~0001541

eureka (reporter)

Hi trevormorse,

nowhere in particular because "compare" is overloaded in class w2p_Utilities_Date and there is no call of this method with the third parameter.
But this function is not safe ..... this is potentially source of problems ...

~0003506

caseydk (administrator)

The timezone is preserved now.. not sure when the fix was applied though. :(

~0003851

caseydk (administrator)


I'm changing this issue to acknowledged.

While it's resolved in the v4.0 development branch. That is going to be reviewed commit by commit and merged into a new development branch over the next couple months.
+Notes

-Issue History
Date Modified Username Field Change
2010-12-25 02:39 eureka New Issue
2010-12-25 05:19 caseydk Status new => assigned
2010-12-25 05:19 caseydk Assigned To => trevormorse
2011-01-03 01:33 eureka Note Added: 0001517
2011-01-05 15:48 trevormorse Note Added: 0001521
2011-01-06 15:33 trevormorse Note Added: 0001525
2011-01-08 10:04 eureka Note Added: 0001541
2011-08-09 13:11 caseydk Project Pending Requests => v4.0 Release (Planning)
2014-01-21 17:57 caseydk Target Version => 4.0
2014-03-30 22:13 caseydk Category General => Core Infrastructure
2014-06-21 20:21 caseydk Note Added: 0003506
2014-06-21 20:21 caseydk Status assigned => resolved
2014-06-21 20:21 caseydk Fixed in Version => 4.0
2014-06-21 20:21 caseydk Resolution open => fixed
2014-06-21 20:21 caseydk Assigned To trevormorse => caseydk
2016-12-29 10:16 caseydk Status resolved => acknowledged
2016-12-29 10:16 caseydk Note Added: 0003851
+Issue History