2017-11-20 05:32 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000672v2.3 Release (Closed)[All Projects] Generalpublic2011-03-24 09:53
Reporteregemme 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.3 
Summary0000672: Gantt pdf fails
DescriptionWhen generating the task Gantt pdf, this error occurs.

JpGraph Error You have specified a constrain from row=1 to row=23 which does not have any activity. Depending on the chosen project, the row numbers varies. When I choose a task without dependancies (no related tasks), the pdf gets generated, but get an IE error. Nothing on the php log. However, pdf file exists in the files/temp folder.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001504

egemme (reporter)

Last edited: 2010-12-27 07:35

This issue divides in two:

1. handling of contrains
2. streaming the pdf

In issue 2, it appears the ob_end_clean doesn't react well. Commenting it makes everything happen. But the streamed pdf also contains the html page itself as expected. ob_end_clean looks misplaced to me. It should rather preceed the mime headers so the stream is cleaned out from the html page itself. However, wherever placed, ob_end_clean seems to block everything. Also when commenting ob_end_clean for letting the stream go through, I noticed the pdf is missing a lot of lines at the end. This is not a show stopper, but since I once asked for Gantt export, I was glad to see it !!

~0001548

axfeel (reporter)

Hi ! Which file has "ob_end_clean" expression to comment out ? There is no pdf file in files/temp folder

~0001591

egemme (reporter)

Hi the file I'm referring to is gantt_pdf.php in tasks module.

But just to make sure I don't mislead your search, does the Gantt to pdf works on your desktop? If so, try with a Gantt with dynamic tasks which seems to be the first hurdle on my side.

Eventhough I use a project having no dynamic tasks, it goes a little further but never come to download the pdf but display a generic IE error on screen. This seems to be caused by the either erroneous or misplace ob_end_clean which actually flushes the page before it even reach the end.

Do you use FF or IE? It may be the reason why...

~0001593

caseydk (administrator)


Can someone give me a database that demonstrates thisconsistently? I'm having trouble duplicating it myself..

~0001599

caseydk (administrator)

Resolved in r1613 by hacking jpGraph to catch the bad dependency check
+Notes

-Issue History
Date Modified Username Field Change
2010-12-27 06:19 egemme New Issue
2010-12-27 07:34 egemme Note Added: 0001504
2010-12-27 07:35 egemme Note Edited: 0001504
2011-01-12 05:39 axfeel Note Added: 0001548
2011-01-31 21:29 egemme Note Added: 0001591
2011-02-05 06:11 caseydk Note Added: 0001593
2011-02-05 06:11 caseydk Status new => feedback
2011-02-07 19:18 caseydk Note Added: 0001599
2011-02-07 19:18 caseydk Status feedback => resolved
2011-02-07 19:18 caseydk Resolution open => fixed
2011-02-07 19:18 caseydk Assigned To => caseydk
2011-02-07 19:19 caseydk Project v2.2 Release (Closed) => v2.3 Release (Closed)
2011-03-24 09:53 caseydk Fixed in Version => 2.3
2011-03-24 09:53 caseydk Status resolved => closed
+Issue History