Anonymous Login
2019-08-25 21:36 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000702v2.3 Release (Closed)[All Projects] Generalpublic2011-03-24 09:53
Reporternimbus 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.3 
Summary0000702: function projectSelectWithOptGroup shows duplicate result
DescriptionIn some modules that use this function (Project add/edit - Copy tasks; File: add/edit)

1. I ran some test and it have result like in Picture No.1, it some project repeat 0000011:0000010 times. There are no duplicate id or name in database ( I checked by phpmyadmin)
2. So I add DISTINCT keyword into line 242 of: includes/main_functions.php:
   $q->addQuery('DISTINCT pr.project_id, co.company_name, project_name');
3. Now it work ok as in Picture No. 2.
TagsNo tags attached.
Attached Files
  • zip file icon Bug1.zip (96,498 bytes) 1969-12-31 16:00

-Relationships
+Relationships

-Notes

~0001577

caseydk (administrator)

Wait.. wait.. wait.. you submit a bug report *and* the fix for it? What were you thinking?

With more people like you around... well, this would be an even better place to be.

Nice job and thanks. :)

~0001578

nimbus (reporter)

:)

Actually, I'm not good at coding. I just try to solve problems arise with my installation and log them here for your ref.

About this bug, I could not trace further due to limit experience in coding. However this solution work good for me at the moment.

Enjoy weekend.

~0001581

caseydk (administrator)

Resolved as described in r1606;
+Notes

-Issue History
Date Modified Username Field Change
2011-01-22 09:53 nimbus New Issue
2011-01-22 09:53 nimbus File Added: Bug1.zip
2011-01-22 12:52 caseydk Status new => assigned
2011-01-22 12:52 caseydk Assigned To => caseydk
2011-01-22 12:52 caseydk Note Added: 0001577
2011-01-22 17:32 nimbus Note Added: 0001578
2011-01-23 23:13 caseydk Project v2.2 Release (Closed) => v2.3 Release (Closed)
2011-01-23 23:14 caseydk Note Added: 0001581
2011-01-23 23:14 caseydk Status assigned => resolved
2011-01-23 23:14 caseydk Resolution open => fixed
2011-03-24 09:53 caseydk Fixed in Version => 2.3
2011-03-24 09:53 caseydk Status resolved => closed
+Issue History