Anonymous Login
2019-07-20 07:11 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000703v4.0 Release (Planning)Translationspublic2016-12-29 10:16
Reporterpocasolta 
Assigned Tocaseydk 
PrioritynormalSeveritytextReproducibilityalways
StatusacknowledgedResolutionfixed 
Product Version 
Target VersionFixed in Version4.0 
Summary0000703: Some translated fields which contain the apostrophe char cause errors
DescriptionSome of the translations with an apostrophe ( ' ) break javascript.
for instance: the 'save' button when creating a new task. if the apostrophe is in its button name, the button doesn't work because of a javascript error.
the only way I found to solve this (while maintaining the apostrophe) is to modify the source files:

in \module\tasks\addedit.php I replaced this:
var task_name_msg = '<php>_('taskName'); ?>';
var task_start_msg = '<php>_('taskValidStartDate'); ?>';
var task_end_msg = '<php>_('taskValidEndDate'); ?>';

with this:
var task_name_msg = "<php>_('taskName'); ?>";
var task_start_msg = "<php>_('taskValidStartDate'); ?>";
var task_end_msg = "<php>_('taskValidEndDate'); ?>";
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001892

caseydk (administrator)

It looks like all it needs is having the UI_OUTPUT_JS flag added.

Benjamin, could you take a look at this one and confirm?

~0002008

caseydk (administrator)

Ping?

~0003693

caseydk (administrator)

Last edited: 2014-10-12 18:06

View 2 revisions

Patch applied as described:
https://github.com/web2project/web2project/commit/5cd01561d829c4c674186efd05d557768815546c

~0003816

caseydk (administrator)


I'm changing this issue to acknowledged.

While it's resolved in the v4.0 development branch. That is going to be reviewed commit by commit and merged into a new development branch over the next couple months.
+Notes

-Issue History
Date Modified Username Field Change
2011-01-24 22:33 pocasolta New Issue
2011-02-08 06:08 caseydk Project v2.2 Release (Closed) => v2.3 Release (Closed)
2011-03-22 23:18 caseydk Project v2.3 Release (Closed) => v2.4 Release (Closed)
2011-05-02 21:52 caseydk Note Added: 0001892
2011-05-02 21:52 caseydk Status new => assigned
2011-05-02 21:52 caseydk Assigned To => bigbluehat
2011-07-03 23:41 caseydk Note Added: 0002008
2011-07-18 12:20 caseydk Project v2.4 Release (Closed) => Pending Requests
2014-01-21 17:56 caseydk Target Version => 4.x
2014-02-27 00:34 caseydk Product Version 2.2 =>
2014-02-27 00:34 caseydk Target Version 4.x =>
2014-04-05 17:24 caseydk Category General => Translations
2014-10-12 18:05 caseydk Project Pending Requests => v4.0 Release (Planning)
2014-10-12 18:05 caseydk Note Added: 0003693
2014-10-12 18:05 caseydk Status assigned => resolved
2014-10-12 18:05 caseydk Fixed in Version => 4.0
2014-10-12 18:05 caseydk Resolution open => fixed
2014-10-12 18:05 caseydk Assigned To bigbluehat => caseydk
2014-10-12 18:06 caseydk Note Edited: 0003693 View Revisions
2016-12-29 10:16 caseydk Status resolved => acknowledged
2016-12-29 10:16 caseydk Note Added: 0003816
+Issue History