Anonymous Login
2019-09-16 09:16 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000714v2.3 Release (Closed)[All Projects] Generalpublic2011-03-24 09:50
Reportereureka 
Assigned Tocaseydk 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
Product Version2.3 
Target VersionFixed in Version2.3 
Summary0000714: Make add-on module names translatable
DescriptionI suggest adding the name (mod_ui_name) of the add-on modules in the file "locales/en/comminc.inc" in order to make them translatable.

These names are :
FlexReports
Help Desk
Mantis
Notebook
Project Importer
Risks
Time Card
TodoList
Working time
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001595

eureka (reporter)

i meant: locales/en/common.inc
sorry !

~0001640

Pierre (reporter)

Are you talking about 3rd party modules? Optional things?
I am not really into the whole project here (yet) but I find it be better to have each module keep it's translation instead of putting it in one global project file.
If I were to make a new module for subversion integration, it is totally not realistic to assume I add it to this file mentioned. Instead it must be contained in my module "space".

Since I assume this is the best way, I would even do this for all modules. Why handle internal modules different from the outside ones?
I know it's not so good to have localization spread out, but this way it's at least consistent.

~0001642

eureka (reporter)

Pierre,

When the menu bar is displayed, the language file of the module is not yet loaded

Do you have a better solution?

~0001646

Pierre (reporter)

I have not looked into how modules work. But it seems there is some way to install modules. Why not integrate into the install process some basic loca text exchange?
So by installing a module it the module name (or whatever else is important) will be stored in the database for all available translations.

~0001647

caseydk (administrator)

@Pierre - Good idea. The module install should handle adding these terms to the translation files. The only potential issue I see is with file permissions but if someone is using non-English already, odds are that the permissions are correct.

@Eureka - what do you think?

~0001652

eureka (reporter)

these terms are already in the translation files of the add-on modules but when the menu is displayed, only "common.inc" and the translation file of the current module are in memory (see locales/core.php). the names of other modules remain untranslated.

ok, if the module install extracts these terms from the translation files then inserts them in "common.inc" (not in the database) for all available translations.

~0001744

caseydk (administrator)

Resolved in r1760

~0001770

caseydk (administrator)

Closed in preparation for v2.3 release.
+Notes

-Issue History
Date Modified Username Field Change
2011-02-06 10:47 eureka New Issue
2011-02-06 10:51 eureka Note Added: 0001595
2011-02-17 08:59 Pierre Note Added: 0001640
2011-02-17 09:23 eureka Note Added: 0001642
2011-02-17 23:49 Pierre Note Added: 0001646
2011-02-18 21:13 caseydk Note Added: 0001647
2011-02-19 01:59 eureka Note Added: 0001652
2011-03-22 22:43 caseydk Note Added: 0001744
2011-03-22 22:43 caseydk Status new => resolved
2011-03-22 22:43 caseydk Resolution open => fixed
2011-03-22 22:43 caseydk Assigned To => caseydk
2011-03-24 09:50 caseydk Note Added: 0001770
2011-03-24 09:50 caseydk Status resolved => closed
2011-03-24 09:50 caseydk Fixed in Version => 2.3
+Issue History