Anonymous Login
2021-10-17 19:26 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000731v2.3 Release (Closed)[All Projects] Generalpublic2011-03-24 09:53
Reportergioalhaz 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
Product Version 
Target VersionFixed in Version2.3 
Summary0000731: Support of UTF-8 in Database
DescriptionUnfortunatly u didn't have native support of utf8 in database. Tables are in latin1 encoding (see install package).
So data in tables are unreadable for third party software or for human.

As example, I'm sending you screen shot of QueryBrowser.
Insteed of garbage on 2,3,4 lines must be Georgian letters like in new record line (Green fields)

I think its a database layer fault, because changing table locale to UTF8 do not help
TagsNo tags attached.
Attached Files
  • png file icon utf8.png (20,425 bytes) 1969-12-31 16:00 -
    png file icon utf8.png (20,425 bytes) 1969-12-31 16:00 +

-Relationships
duplicate of 0000598feedbackcaseydk Pending Requests adodb-mysql does not set default character set for db connection, this can lead in unusable database content 
+Relationships

-Notes

~0001685

caseydk (administrator)

Last edited: 2011-02-27 05:29

Update 6 on the database converted the tables to utf-8. Look into issue 0000598 and see if changing the connection's character set solves it. You *may* have to change the character set, submit some new data, and attempt to view it again.

~0001691

gioalhaz (reporter)

Yes, I change table encoding and then add some changes to your php code to change connection encoding.
And this helps.
Thanks!

~0001693

caseydk (administrator)

"Helps" as in solved it? If so, we can close this issue in favor of 0000598.

~0001694

gioalhaz (reporter)

Yes u can (close) :)
+Notes

-Issue History
Date Modified Username Field Change
2011-02-23 01:11 gioalhaz New Issue
2011-02-23 01:11 gioalhaz File Added: utf8.png
2011-02-23 22:47 caseydk Relationship added child of 0000598
2011-02-26 19:05 caseydk Note Added: 0001685
2011-02-27 01:26 gioalhaz Note Added: 0001691
2011-02-27 05:29 caseydk Note Edited: 0001685
2011-02-27 05:30 caseydk Note Added: 0001693
2011-02-27 10:54 gioalhaz Note Added: 0001694
2011-02-27 15:10 caseydk Relationship replaced duplicate of 0000598
2011-02-27 15:10 caseydk Duplicate ID 0 => 598
2011-02-27 15:10 caseydk Status new => resolved
2011-02-27 15:10 caseydk Resolution open => duplicate
2011-02-27 15:10 caseydk Assigned To => caseydk
2011-02-28 20:29 caseydk Project v2.2 Release (Closed) => v2.3 Release (Closed)
2011-03-24 09:53 caseydk Fixed in Version => 2.3
2011-03-24 09:53 caseydk Status resolved => closed
+Issue History