Anonymous Login
2019-12-08 13:13 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000733v2.3 Release (Closed)[All Projects] Generalpublic2011-03-24 09:52
Reportergioalhaz 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
Product Version 
Target VersionFixed in Version2.3 
Summary0000733: utf rendering in gantt chart generates ??? symbols
DescriptionThe previous issues that I report about were utf encoding in database. When I correct this issue (change database table encoding and change some code to specify utf encoding for connection) I hope that gantt chart will render Georgian alphabet correctly. But No. This didn't help. After little investigation I found incorrect code in you sources.

Let take file modules\projects\gantt.php .
Find code
==============
        if ($locale_char_set == 'utf-8') {
            $name = strlen(utf8_decode($p['project_name'])) > 25 ? substr(utf8_decode($p['project_name']), 0, 22) . '...' : utf8_decode($p['project_name']);
        } else {
            //while using charset different than UTF-8 we need not to use utf8_decode
            $name = strlen($p['project_name']) > 25 ? substr($p['project_name'], 0, 22) . '...' : $p['project_name'];
        }
==============
As you see, you use utf8_decode in case when locale charset is utf. But you do not need to do it. Just change change part above with my version:

$name = mb_strlen($p['project_name']) > 25 ? mb_substr($p['project_name'], 0, 22) . '...' : $p['project_name'];
TagsNo tags attached.
Attached Files

-Relationships
duplicate of 0000727new Pending Requests Georgian letters appears as ???? 
child of 0000429closedcaseydk v2.3 Release (Closed) Some character set encoding issue on Gantt charts 
+Relationships

-Notes

~0001695

eureka (reporter)

hi gioalhaz,

gantt.php was rewritten for version 2.3 :
http://web2project.svn.sourceforge.net/viewvc/web2project/trunk/modules/projects/gantt.php?revision=1652&view=markup
utf8_decode is no longer used ;)

~0001696

caseydk (administrator)

RobertBasic has made some major updates here too:

https://github.com/robertbasic/web2project/commits/ganttunicode

~0001709

caseydk (administrator)

This is so close to 0000727 that I'm closing it as a dupe. The Unicode updates help out quite a bit of this problem but not all of it.

~0001782

caseydk (administrator)

Closed in preparation for v2.3 release.
+Notes

-Issue History
Date Modified Username Field Change
2011-02-27 11:14 gioalhaz New Issue
2011-02-27 14:53 eureka Note Added: 0001695
2011-02-27 17:50 caseydk Status new => assigned
2011-02-27 17:50 caseydk Assigned To => caseydk
2011-02-27 17:50 caseydk Project v2.2 Release (Closed) => v2.3 Release (Closed)
2011-02-27 17:50 caseydk Relationship added child of 0000429
2011-02-27 17:53 caseydk Note Added: 0001696
2011-03-07 16:44 caseydk Relationship added duplicate of 0000727
2011-03-07 16:45 caseydk Note Added: 0001709
2011-03-07 16:45 caseydk Duplicate ID 0 => 727
2011-03-07 16:45 caseydk Status assigned => resolved
2011-03-07 16:45 caseydk Resolution open => duplicate
2011-03-24 09:52 caseydk Note Added: 0001782
2011-03-24 09:52 caseydk Status resolved => closed
2011-03-24 09:52 caseydk Fixed in Version => 2.3
+Issue History