Anonymous Login
2019-08-22 05:08 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000745v3.0 Release[All Projects] Generalpublic2013-08-28 11:25
ReporterMiraKlim 
Assigned Tocaseydk 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0000745: New project creation error , child project not visible in list of project
Description1) When a new project is created and any of budget field remains empty, project is not stored correctly. An error message "incorrect decimal value: '' for column 'project_target_budget' at row 1" is shown.

2) If a new project is created with parent project created with error message mentioned above, then child project is not shown anywhere in list of project
Steps To Reproduce1) Create new project, do not fill "Parent project" field, leave field(s) Target Budget and Actual Budget empty.
Then press "Submit"

Error doesn't occur when project has a valid parent project.

2) Create another new project, set parent project to project created in 1), fill-in badget fields. Press "Submit"

3) Open Project list. Project created in 2) is not listed anywhere.
Additional InformationC:\ComplexWebServer\http_users\web2project-v2.3-test\classes\w2p\Database\Query.class.php(1116): query failed(UPDATE `projects` SET `project_company` = '1', `project_name` = 'Major project 2', `project_short_name` = 'Major proj', `project_owner` = '2', `project_url` = '', `project_demo_url` = '', `project_start_date` = '2011-03-11 00:00:00', `project_status` = '0', `project_color_identifier` = 'FFFFFF', `project_description` = 'Project without budget', `project_target_budget` = '', `project_actual_budget` = '', `project_creator` = '2', `project_active` = 1, `project_private` = 0, `project_priority` = '0', `project_type` = '0', `project_parent` = '6', `project_location` = '', `project_last_task` = 0, `project_original_parent` = '6', `project_departments` = '', `project_contacts` = '', `project_updated` = '2011-03-11 13:09:55', `project_created` = '2011-03-11 13:09:55' WHERE project_id = '6') - error was: Incorrect decimal value: '' for column 'project_target_budget' at row 1

ERROR: C:\ComplexWebServer\http_users\web2project-v2.3-test\classes\w2p\Database\Query.class.php(1116) : query failed(UPDATE `projects` SET `project_company` = '1', `project_name` = 'Major project 2', `project_short_name` = 'Major proj', `project_owner` = '2', `project_url` = '', `project_demo_url` = '', `project_start_date` = '2011-03-11 00:00:00', `project_status` = '0', `project_color_identifier` = 'FFFFFF', `project_description` = 'Project without budget', `project_target_budget` = '', `project_actual_budget` = '', `project_creator` = '2', `project_active` = 1, `project_private` = 0, `project_priority` = '0', `project_type` = '0', `project_parent` = '6', `project_location` = '', `project_last_task` = 0, `project_original_parent` = '6', `project_departments` = '', `project_contacts` = '', `project_updated` = '2011-03-11 13:09:55', `project_created` = '2011-03-11 13:09:55' WHERE project_id = '6') - error was: Incorrect decimal value: '' for column 'project_target_budget' at row 1
Backtrace:
0 C:\ComplexWebServer\http_users\web2project-v2.3-test\classes\w2p\Database\Query.class.php:1116 dprint()
1 C:\ComplexWebServer\http_users\web2project-v2.3-test\classes\w2p\Database\Query.class.php:1673 exec()
2 C:\ComplexWebServer\http_users\web2project-v2.3-test\classes\w2p\Core\BaseObject.class.php:237 updateObject()
3 C:\ComplexWebServer\http_users\web2project-v2.3-test\modules\projects\projects.class.php:553 store()
4 C:\ComplexWebServer\http_users\web2project-v2.3-test\modules\projects\do_project_aed.php:18 store()
5 C:\ComplexWebServer\http_users\web2project-v2.3-test\index.php:251 require()
TagsNo tags attached.
Attached Files

-Relationships
related to 0000963closedcaseydk Subproject icon does no appear when multi-subproject context is set 
+Relationships

-Notes

~0001748

caseydk (administrator)

What version of MySQL are you using?

I can't reproduce this one at all..

~0001751

MiraKlim (reporter)

I can confirm that the problem depends on MYSQL version.

I originally found the issue on system with MYSQL 5.1.30-community

After your comment I did another test on different system with MySQL 5.0.51a
Here I wasn't able to reproduce it.

~0001792

caseydk (administrator)

Since this is a rare situation completely dependent on the MySQL version, I'm moving this to a Pending Request for the time being. If others run into the same problem, I'll nominate it for high priority in the v3.0 release.

Also.. since the error is happening on Save.. are you sure the Project is getting saved at all?

~0001829

MiraKlim (reporter)

The project is saved in database, but not all project attributes are stored. Not sure exactly what but the result is that lots which have the "incomplete project" as a parent are not visible in list of projects.

I can live with this issue but it would be annoying for new users of W2P

~0002370

caseydk (administrator)

The first part of this one was resolved a while back by setting defaults on the CProject class.

The second part of this one is covered by 0000963.
+Notes

-Issue History
Date Modified Username Field Change
2011-03-11 04:32 MiraKlim New Issue
2011-03-16 22:02 caseydk Project v2.2 Release (Closed) => v2.3 Release (Closed)
2011-03-22 23:21 caseydk Note Added: 0001748
2011-03-22 23:21 caseydk Status new => feedback
2011-03-23 01:35 MiraKlim Note Added: 0001751
2011-03-24 22:49 caseydk Priority normal => high
2011-03-24 23:17 caseydk Note Added: 0001792
2011-03-24 23:17 caseydk Project v2.3 Release (Closed) => Pending Requests
2011-03-31 03:54 MiraKlim Note Added: 0001829
2011-11-26 22:45 caseydk Project Pending Requests => v3.0 Release
2011-12-27 23:12 caseydk Relationship added related to 0000963
2011-12-27 23:12 caseydk Note Added: 0002370
2011-12-27 23:12 caseydk Status feedback => resolved
2011-12-27 23:12 caseydk Resolution open => fixed
2011-12-27 23:12 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:25 caseydk Status resolved => closed
+Issue History