Anonymous Login
2019-08-23 20:09 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000774v2.4 Release (Closed)[All Projects] Generalpublic2011-08-16 23:44
Reporterckwanhu 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.4 
Summary0000774: Tasks of the Todo Gantt are created Twice
DescriptionI tried the Todo List and the Todo Gantt.

The tasks in the Todo Gantt are created twice (cf images).
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0000905closedcaseydk Pending Requests duplicated tasks in user's TODO gantt chart 
+Relationships

-Notes

~0001870

ckwanhu (reporter)

I have created more tasks after the upgrade.

The new tasks are still created twice. So I don't think this problem was caused by the upgrade.

~0001940

ckwanhu (reporter)

Hello,

I think I may have found a pattern.

I am not sure, but it seems that it is hapenning because of sub projects.

I do have projects which are not subprojects, and for them, everything is all right.
But, if subprojects are involved. There is duplication.

It may be just a coincidence.

~0001979

econ_dude (reporter)

I made showgtask(), in line 288 in /modules/tasks/gantt.php, conditional based on project_id and all of my gantt charts are displaying without duplicate tasks. I might not have tested all gantts that can present in w2p. Note: it looks like the gantt code (maybe from dP) could use some major refactoring, so this is more of a hack/fix until someone can clean it up.

if ($project_id) {
   showgtask($t);
}

http://forums.web2project.net/viewtopic.php?p=11746&highlight=#11746

~0002018

vsonora (reporter)

I submited a pull request. Rewrote a couple of lines in both showgtask() and findgchild() and also two sections of gantt.php code related to tasks handling (there were some limes that accessed directly to gantt_arr variable so I tried to avoid that).

~0002042

caseydk (administrator)

Resolved in r1991 via pull request;
+Notes

-Issue History
Date Modified Username Field Change
2011-04-11 00:58 ckwanhu New Issue
2011-04-11 00:58 ckwanhu File Added: BugTodoGantt.zip
2011-04-13 06:49 caseydk Project v2.3 Release (Closed) => v2.4 Release (Closed)
2011-04-19 06:41 ckwanhu Note Added: 0001870
2011-05-25 00:10 ckwanhu Note Added: 0001940
2011-06-14 16:38 econ_dude Note Added: 0001979
2011-07-07 05:04 vsonora Note Added: 0002018
2011-07-17 20:43 caseydk Note Added: 0002042
2011-07-17 20:43 caseydk Status new => resolved
2011-07-17 20:43 caseydk Resolution open => fixed
2011-07-17 20:43 caseydk Assigned To => caseydk
2011-07-30 13:21 caseydk Relationship added has duplicate 0000905
2011-08-16 23:44 caseydk Status resolved => closed
2011-08-16 23:44 caseydk Fixed in Version => 2.4
+Issue History