Anonymous Login
2020-08-13 17:00 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000794v2.4 Release (Closed)[All Projects] Generalpublic2011-08-16 23:46
Reportergeorgils 
Assigned Torobertbasic 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version2.4 
Summary0000794: UTF-8 issues : *some* non-English characters are displayed corrupt
DescriptionOn a fresh v.2.3.1 install I get *some* non-English characters displayed corrupt (see image file). I am using cyrillic, browser encoding set to UTF8.
Strange enough the problem occurs only with a couple of letters (?, ?, ...) while everything else is displaying fine.
Tried setting the Host Locale to "bg" (Bulgarian) but nothing changes.
Checked some source HTML that the browser gets - it has all meta and form attributes correctly set to utf-8.

Additional InformationAll 81 tables come with "utf8_general-ci" collation except table contacts_methods, which is has "latin1_swedish_ci". I change it to "utf8_general-ci", the varchar fields too but it obviously has nothing to do with the project name. I got an error message using SmartSearch, which complained about different collations but it's another issue, I guess.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001897

georgils (reporter)

Even stranger, browsing the "projects" table with phpMyAdmin I see the whole project_name field string oddly encoded (browser encoding still UTF8), see Image2.png. This is the same string that stores the project name from Image1.png, where only the 3rd letter displays incorrectly...

~0001898

georgils (reporter)

And something else I just noticed: when I edit the project name and check Notify by Email Project owner, the e-mail I get has the project name displayed correctly.
I guess the mailing function takes the value from the form directly rather than reading it from the DB, which might probably isolate the problem to a DB-only issue...
It's a non-production installation, I can provide login details if you want to take a look.

~0001899

georgils (reporter)

Changing some System Lookup Values that include the problematic cyrillic characters leads to making them totally invisible in the dropdown select list.
BTW trying to edit the project name directly in the "projects" table leads to a completely unreadable (in the frontend) project name.

~0001921

robertbasic (developer)

georgils, could you please show what characters are problematic? looks like even the issue tracker doesn't like them as all I see are "?"s. thanks

~0001922

georgils (reporter)

After testing the entire Bulgarian (a cyrillic subset) alphabet it comes out that there are only two problematically displayed symbols (see attached file problematic.png).
These are (decimal) 200 and 248 from the Windows-1251 encoding table (http://en.wikipedia.org/wiki/Windows-1251).

~0001923

robertbasic (developer)

georgils could you please provide me the login details to your system as I can not reproduce this issue? you can send it to robertbasic.com@gmail.com

thanks

~0001926

georgils (reporter)

Just sent the e-mail.

~0001929

robertbasic (developer)

Completely baffled over this one: can reproduce on *your* server, but can not reproduce on any other server. Plus the fact that it is happening only with two! characters is not helping either and makes the issue even more obscure.

georgils, I'd need several things from you. First, what is the collation of the database itself? Could you please reinstall your w2p instance and see if that helps? Also, if you could install the 2.3.0 version, that'd be great, just to see if earlier versions are affected too. If the issue still remains, please try to install it on a completely different server.

thanks

~0001932

georgils (reporter)

MySQL connection collation: utf8_general_ci
In my dedicated to W2P database every table has the same collation - utf8_general_ci.

I just created a local installation on a XAMPP stack on Win XP (if this matters) and there seems to be no problem at all...

I'll try later a 2.3.0 install on the same host's server (where I got the problem) and let you know. But I am already convinced it's not a W2P bug rather than some server-specific issue... It seems too weird and too specific to be worth tracking down and I guess you can close the issue. Unless you are curious to know what happened with the 2.3.0 install ;)

Thank you!

best regards,
Georgi

~0001933

georgils (reporter)

Huh, I forgot to make clear I am using web2project-trunk-revision-1889-2011-05-07 rather than the official 2.3.1 installation from SF and everything said concerns this one...

Now to the 2.3.0 installation:
1. I get two alerts on step 1 of the installation process - LDAP Support: Not available and Server API: CGI mode is likely to have problems.
2. The installation goes smoothly
3. I get the same problem with the same two letters :( This time only they are displayed slightly differently compared to the first install (squares and question marks, see file 2.3.0.png)

So obviously it's not a version issue.
Anyway as long as it does not affect my searches (words containing the problematic characters) it's fine with me. And it seems noone else is having this issue, so maybe we'd better close it.

thank you

Georgi

~0001934

robertbasic (developer)

ok, this is apparently a server misconfiguration issue, really can't think of anything else that could cause this kind of behaviour.

closing it as not an issue.

thank you Georgi for all your help :)
+Notes

-Issue History
Date Modified Username Field Change
2011-05-04 14:24 georgils New Issue
2011-05-04 14:24 georgils File Added: Image1.png
2011-05-04 14:29 georgils File Added: Image2.png
2011-05-04 14:33 georgils Note Added: 0001897
2011-05-04 14:54 georgils Note Added: 0001898
2011-05-04 15:03 georgils Note Added: 0001899
2011-05-21 22:26 caseydk Status new => assigned
2011-05-21 22:26 caseydk Assigned To => robertbasic
2011-05-21 22:27 caseydk Project v2.3 Release (Closed) => v2.4 Release (Closed)
2011-05-21 23:25 robertbasic Note Added: 0001921
2011-05-21 23:45 georgils Note Added: 0001922
2011-05-21 23:46 georgils File Added: problematic.png
2011-05-22 09:10 robertbasic Note Added: 0001923
2011-05-22 10:37 georgils Note Added: 0001926
2011-05-22 12:09 robertbasic Note Added: 0001929
2011-05-23 01:03 georgils Note Added: 0001932
2011-05-23 02:08 georgils Note Added: 0001933
2011-05-23 02:08 georgils File Added: 2.3.0.png
2011-05-23 08:53 robertbasic Note Added: 0001934
2011-05-23 08:54 robertbasic Status assigned => resolved
2011-05-23 08:54 robertbasic Resolution open => unable to reproduce
2011-08-16 23:46 caseydk Status resolved => closed
2011-08-16 23:46 caseydk Fixed in Version => 2.4
+Issue History