Anonymous Login
2019-08-20 00:25 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000809v2.4 Release (Closed)[All Projects] Generalpublic2011-08-16 23:38
Reporterhias 
Assigned Torobertbasic 
PriorityurgentSeverityblockReproducibilityrandom
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.4 
Summary0000809: Login Box disappears
DescriptionEverytime some of our users goes to the Login page, the login will porperly appear. Whenever they refresh the page e.g. F5. The Login Box disappears. We can avoid that problem by changing the default Style of the login (so far..)

I tried to pinpoint the error and found that the problem lies in the php function 'styleRenderTopBox'. Whenever the page is refreshed, the sourcecode will stop where this function is called. (see Additional Functions)

I'm running PHP Version 5.3.2-1
Additional InformationFirst visit:
                <!--please leave action argument empty -->
        <form method="post" action="index.php" name="loginform" accept-charset="utf-8">
            <table style="border-style:none;" align="center" border="0" width="250" cellpadding="0" cellspacing="0" class="std">
                <input type="hidden" name="login" value="1305878560"/>
                <input type="hidden" name="lostpass" value="0"/>
                <input type="hidden" name="redirect" value=""/>
                <tr>
                    <td colspan="2">
                                            </td>
                </tr>
                <tr>
                ...
etc. WORKING FINE!

after refresh:

                <!--please leave action argument empty -->
        <form method="post" action="index.php" name="loginform" accept-charset="utf-8">
            <table style="border-style:none;" align="center" border="0" width="250" cellpadding="0" cellspacing="0" class="std">
                <input type="hidden" name="login" value="1305878790" />
                <input type="hidden" name="lostpass" value="0" />
                <input type="hidden" name="redirect" value="" />
                <tr>
                    <td colspan="2">
this is where the code ends.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001916

hias (reporter)

After some additional testing it resulted that changing the design won't help all the time.
the ticket's reproducibility should be randomly

~0001919

caseydk (administrator)

What browser(s) and version(s)?

~0001930

hias (reporter)

Firefox 4.0
IE 8

~0001944

robertbasic (developer)

Last edited: 2011-05-28 00:57

I'm unable to reproduce this issue.

On what kind of server does your w2p instance run? OS, Apache, MySQL, PHP versions? Is PHP running as an Apache module or through cgi/fast-cgi?

Also, your clients what OS and browsers use?

~0001947

hias (reporter)

OS: Ubuntu 10.04.2
Apache: 2.2.14
MySQL: 5.1.41
PHP: 5.3.2-1
(they're all from the ubuntu default repository)

OS/Browser
Windows Vista/7 : Firefox 4.0
Windows XP : IE 8
Windows Vista : IE 9

~0001953

caseydk (administrator)

I wasn't able to reproduce this one but I added function checks around the calls to make sure we were covered;
That's in r1938;
+Notes

-Issue History
Date Modified Username Field Change
2011-05-20 00:13 hias New Issue
2011-05-20 00:22 hias Note Added: 0001916
2011-05-21 22:19 caseydk Reproducibility always => random
2011-05-21 22:24 caseydk Note Added: 0001919
2011-05-21 22:24 caseydk Status new => feedback
2011-05-21 22:27 caseydk Project v2.3 Release (Closed) => v2.4 Release (Closed)
2011-05-22 22:10 hias Note Added: 0001930
2011-05-24 21:47 caseydk Status feedback => assigned
2011-05-24 21:47 caseydk Assigned To => robertbasic
2011-05-24 22:10 caseydk Priority normal => high
2011-05-24 22:10 caseydk Priority high => urgent
2011-05-28 00:55 robertbasic Note Added: 0001944
2011-05-28 00:57 robertbasic Note Edited: 0001944
2011-05-29 22:50 hias Note Added: 0001947
2011-05-30 20:22 caseydk Note Added: 0001953
2011-05-30 20:22 caseydk Status assigned => resolved
2011-05-30 20:22 caseydk Fixed in Version => 3.0
2011-05-30 20:22 caseydk Resolution open => fixed
2011-08-16 23:38 caseydk Status resolved => closed
2011-08-16 23:38 caseydk Fixed in Version => 2.4
+Issue History