Anonymous Login
2019-06-25 17:05 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000856v2.4 Release (Closed)[All Projects] Generalpublic2011-08-16 23:38
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.4 
Summary0000856: edit user preferences returns to sysadmin instead of user admin
Descriptionpressing the ok/accept button after eiting some user preferences (e.g. TZ) returns to sysadmin main page.
It would be more logical to go to user admin main page to be able to edit more users.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002031

caseydk (administrator)

While I agree that sending you to the System Admin doesn't make sense, I think it'd be better to go back to the just-edited User's info page. If there are more changes to be made, they can be done right there.

What do you think?

~0002036

opto (manager)

user edit: as admin, I want to go to user list
an individual user might want to return? But he could do the changes on that page before the edit?

~0002046

caseydk (administrator)

Resolved in r1998;

When making the updates just now, I realized that we can't necessarily redirect the user back to the user list because there are three scenarios:

- Editing the default user (id=0), so the redirect should go back to the system admin as it was previously;
- Editing yourself (which doesn't necessarily mean you're an admin), so the redirect should go back to the user itself; or
- Editing a user (which implies you're a user admin), so the redirect could go back to the user list as you wish.

For sanity's sake, I've only implemented the first two instead of doing an additional permissions check and doing the third also/instead.

That's the most logical in my book.. but it's 2:30am here. ;)
+Notes

-Issue History
Date Modified Username Field Change
2011-07-04 22:00 opto New Issue
2011-07-14 23:14 caseydk Project v2.3 Release (Closed) => v2.4 Release (Closed)
2011-07-14 23:18 caseydk Note Added: 0002031
2011-07-14 23:18 caseydk Status new => feedback
2011-07-15 09:10 opto Note Added: 0002036
2011-07-17 23:37 caseydk Note Added: 0002046
2011-07-17 23:37 caseydk Status feedback => resolved
2011-07-17 23:37 caseydk Resolution open => fixed
2011-07-17 23:37 caseydk Assigned To => caseydk
2011-08-16 23:38 caseydk Status resolved => closed
2011-08-16 23:38 caseydk Fixed in Version => 2.4
+Issue History