Anonymous Login
2019-12-05 09:39 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000861v2.4 Release (Closed)[All Projects] Generalpublic2011-08-16 23:38
Reporterw2p_user 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.4 
Summary0000861: Clicking on any of the buttons in the Task List report does not alter the dates
DescriptionThe task list report has buttons like "previous month", "previous Week","Next Week" etc. Clicking on the buttons does not alter the dates in any way. We have to manually set the dates to generate the report.
Additional Informationit looks like we are passing a string instead of an array

tasklist.php
line nos. 43-47

    if ($sign > 0) {
        $end_date->addSpan(new Date_Span("$days,0,0,0"));
    } else {
        $start_date->subtractSpan(new Date_Span("$days,0,0,0"));
    }

I changed this to
    if ($sign > 0) {
        $end_date->addSpan(new Date_Span(array($days,0,0,0)));
    } else {
        $start_date->subtractSpan(new Date_Span(array($days,0,0,0)));
    }

and it started to work.

we need to make changes to the code accordingly.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002115

caseydk (administrator)

Resolved in r2016
+Notes

-Issue History
Date Modified Username Field Change
2011-07-06 05:04 w2p_user New Issue
2011-07-14 23:19 caseydk Project v2.3 Release (Closed) => Pending Requests
2011-07-14 23:19 caseydk Project Pending Requests => v2.4 Release (Closed)
2011-07-23 22:47 caseydk Status new => assigned
2011-07-23 22:47 caseydk Assigned To => caseydk
2011-08-06 23:13 caseydk Note Added: 0002115
2011-08-06 23:13 caseydk Status assigned => resolved
2011-08-06 23:13 caseydk Resolution open => fixed
2011-08-16 23:38 caseydk Status resolved => closed
2011-08-16 23:38 caseydk Fixed in Version => 2.4
+Issue History