Anonymous Login
2019-08-19 03:09 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000890v3.0 Release[All Projects] Generalpublic2013-10-31 06:19
ReporterArtjoms 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0000890: Multiple events created for projects with multiple departments assigned
DescriptionWhen a project is edited and multiple departments are set to one project (in edit project menu, by pressing ctrl) and afterwards creating an event connected with THIS project causes creation of unique event to appear for each department. This really messes up the calendar
Additional Informationsteps to reproduce on Demo server:
1) Create few new departments (dep1, dep2...)
2) create a new project
3) edit this project
4) with pressed CTRL choose multiple departments assigned to project
5) create an event (by selecting create event for THIS EXACT project)
6) Observe calendar - and see multiple identical events created for each department
TagsNo tags attached.
Attached Files
  • jpg file icon bug.jpg (37,566 bytes) 1969-12-31 16:00 -
    jpg file icon bug.jpg (37,566 bytes) 1969-12-31 16:00 +

-Relationships
+Relationships

-Notes

~0002082

Artjoms (reporter)

Solved this issue by adding DISTINCT predicate to file \modules\calendar\calendar.class.php at Line: 645
$$query_set->addQuery('DISTINCT e.*');

Seems that similar problem can be found in report section as well, so DISTINCT predicate can be added in
/Modules/reports/reports/tasklogs.php Line: 165
and
Modules/reports/reports/tasklogs_xp1.php Line: 163
And I think the problem is solved :)

~0002259

caseydk (administrator)

Resolved as described:
https://github.com/caseysoftware/web2project/commit/02cac130c17a3f0784e4ffc4f80917eb93ff33df
+Notes

-Issue History
Date Modified Username Field Change
2011-07-14 12:47 Artjoms New Issue
2011-07-14 12:47 Artjoms File Added: bug.jpg
2011-07-14 22:58 caseydk Project v2.3 Release (Closed) => Pending Requests
2011-07-24 21:55 Artjoms Note Added: 0002082
2011-08-09 12:54 caseydk Project Pending Requests => v3.0 Release
2011-10-21 00:21 caseydk Note Added: 0002259
2011-10-21 00:21 caseydk Status new => resolved
2011-10-21 00:21 caseydk Resolution open => fixed
2011-10-21 00:21 caseydk Assigned To => caseydk
2013-08-28 11:13 caseydk Fixed in Version => 3.0.0
2013-10-31 06:19 caseydk Status resolved => closed
+Issue History