Anonymous Login
2019-06-19 05:46 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000892v2.4 Release (Closed)[All Projects] Generalpublic2011-08-16 23:40
Reporterbucienator 
Assigned Torobertbasic 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.4 
Summary0000892: task email charset encoding does not work
DescriptionWe are using w2p in English, but all the contents are in Hungarian, encoded in UTF-8. The whole site is also encoded in UTF-8, as it is set in locales/*/locales.php.

However, the task email notifications were sent out with iso-8859-15 charset set in the Content-Type header, but the content itself was in UTF-8 in reality.

Content-Type: text/plain; charset="iso-8859-15"

This made the mails quite unreadable where accents were present.
Additional InformationI made a fix for queuescanner.php, that works for me, but I am not sure if it is a general solution:

Index: queuescanner.php
===================================================================
--- queuescanner.php (revision 1985)
+++ queuescanner.php (working copy)
@@ -11,6 +11,8 @@
 $AppUI = new CAppUI;
 $AppUI->setUserLocale();

+$locale_char_set = 'utf-8';
+
 $queue = new w2p_Core_EventQueue();
 $queue->scan();

TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0000803closedrobertbasic Pending Requests Task reminders wrong codification 
+Relationships

-Notes

~0002055

robertbasic (developer)

Assigning to myself, as most likely is related to or is a duplicate of 0000803.

Thanks for the possible fix bucienator, will test and patch if it's OK.

~0002056

robertbasic (developer)

bucienator what version of web2project are you using? I think caseydk fixed this issue with this commit https://github.com/caseysoftware/web2project/commit/3a28d4e5cda706cf6ea4374ab051601a82f99f77#classes/w2p/Utilities/Mail.class.php

Please see classes/w2p/Utilities/Mail.class.php and check line 82.

thanks!

~0002062

bucienator (reporter)

I am using version 2.3.1, which seems not to have the above patch applied. However, the trunk has it, so I guess this issue will be fixed in the next release.

Thank you, and keep up the good work!

~0002063

robertbasic (developer)

Yup, this was fixed by that commit.

Thanks bucienator!

~0002064

robertbasic (developer)

Fixed by caseydk with this commit https://github.com/caseysoftware/web2project/commit/3a28d4e5cda706cf6ea4374ab051601a82f99f77#classes/w2p/Utilities/Mail.class.php
+Notes

-Issue History
Date Modified Username Field Change
2011-07-15 22:50 bucienator New Issue
2011-07-21 06:06 robertbasic Relationship added related to 0000803
2011-07-21 06:06 robertbasic Status new => assigned
2011-07-21 06:06 robertbasic Assigned To => robertbasic
2011-07-21 06:08 robertbasic Note Added: 0002055
2011-07-21 11:16 robertbasic Note Added: 0002056
2011-07-21 11:20 robertbasic Relationship deleted related to 0000803
2011-07-21 11:20 robertbasic Relationship added has duplicate 0000803
2011-07-22 02:01 bucienator Note Added: 0002062
2011-07-22 02:38 robertbasic Note Added: 0002063
2011-07-22 02:39 robertbasic Note Added: 0002064
2011-07-22 02:39 robertbasic Status assigned => resolved
2011-07-22 02:39 robertbasic Resolution open => fixed
2011-08-06 23:19 caseydk Project Pending Requests => v2.4 Release (Closed)
2011-08-16 23:40 caseydk Status resolved => closed
2011-08-16 23:40 caseydk Fixed in Version => 2.4
+Issue History