Anonymous Login
2019-10-18 03:54 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000940v3.0 Release[All Projects] Generalpublic2013-08-28 11:27
Reportermfenoll 
Assigned Tocaseydk 
PrioritylowSeveritytextReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0000940: Text Area Custom Fields trunk text
DescriptionI created many project custom field to add information like project objectives, initial scope, initial risks, justification, stakeholders, etc. But, when I insert data into these fields, the text is trunked around 220~250 characters.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002179

caseydk (administrator)

Have you tried this in v2.4?

~0002180

mfenoll (reporter)

Yes. But I found a workaround/fix:

The problem is that the database field for this information is a varchar with only 255 characters.

A simple workaround I did, was to update this field for 20.000 characters:
ALTER TABLE `custom_fields_values` CHANGE `value_charvalue` `value_charvalue` VARCHAR (20000) CHARACTER SET utf8 COLLATE utf8_general_ci NULL DEFAULT NULL

But I realized that this field is a part of a index, so, it could down the performance.

Then, I did two more updates:
1. Droped the index:
ALTER TABLE `custom_fields_values` DROP INDEX `value_charvalue`

2. Changed the field for TEXT type:
ALTER TABLE `custom_fields_values` CHANGE `value_charvalue` `value_charvalue` TEXT CHARACTER SET utf8 COLLATE utf8_general_ci NULL DEFAULT NULL

Now it works great. I would like to recomend that the default database schema could be changed for this type of field.

Thanks a lot.
Marcelo Fenoll, from Brazil.

~0002348

caseydk (administrator)

Resolved in r2229
+Notes

-Issue History
Date Modified Username Field Change
2011-08-29 11:15 mfenoll New Issue
2011-08-30 20:00 caseydk Note Added: 0002179
2011-08-30 20:00 caseydk Status new => feedback
2011-08-31 05:16 mfenoll Note Added: 0002180
2011-09-03 20:34 caseydk Project v2.3 Release (Closed) => v3.0 Release
2011-09-27 23:48 caseydk Priority normal => low
2011-11-24 22:29 caseydk Status feedback => assigned
2011-11-24 22:29 caseydk Assigned To => caseydk
2011-12-12 06:10 caseydk Note Added: 0002348
2011-12-12 06:10 caseydk Status assigned => resolved
2011-12-12 06:10 caseydk Resolution open => fixed
2013-08-28 11:13 caseydk Fixed in Version => 3.0.0
2013-08-28 11:27 caseydk Status resolved => closed
+Issue History