Anonymous Login
2019-11-15 04:16 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000982v3.0 Release[All Projects] Generalpublic2013-08-28 11:24
Reportersasquatch58 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0000982: Gantt charts display at UTC regardless of user locale
DescriptionTesting V3.0 pre (build 2099)
Gantt charts display shows all task entries at UTC time values and not as per user locale/ timezone.
This problem is present in V2.3.1 and 2.4 as well
Issue is displayed in attached screen captures, very noticeable for entries under NZDST (Pacific/Auckland with Daylight Saving) displaying 13h in the past.
Additional InformationUbuntu 10.04.1 LTS 64bit fully patched.
System timezone set to Pacific/Auckland & linked to ntp.
Testing information:
Using svn to pull current development versions from sourceforge
- config.php points to existing database ie did not create dayabase on install but used a copy of an existing one
- database updates applied
- Documentation, Importers, Exporters, Holiday modules added
- includes and files & files/temp set to permission 777
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002263

caseydk (administrator)

Good catch. It's hard to notice those things when my base timezone is only a few hours off.

Resolved:
https://github.com/caseysoftware/web2project/commit/fd04d0a74ad1ae930b51058ddb5857f864d67edb

~0002265

sasquatch58 (reporter)

Thanks for the update but still issues depending on how the gant chart is selected.
Select a start & end date - the display is fine (uses User Locale)
"Show this month" - the display is fine (uses User Locale)
"Show full project" - the display reverts to using GMT & ignores User Locale

~0002267

sasquatch58 (reporter)

A further update - a pdf generated from the same view has the Gantt views even further back in time. Looks like corrections applied twice. See GanttChart_21.pdf attached above.

~0002287

caseydk (administrator)

I'm marking this one as fixed again to address the original issue.

I can't reproduce the new issue of not applying the timezone conversion when the "show full project" option is used.
+Notes

-Issue History
Date Modified Username Field Change
2011-09-26 02:24 sasquatch58 New Issue
2011-09-26 02:24 sasquatch58 File Added: 2011-09-26 w2p gantt EST user.png
2011-09-26 02:25 sasquatch58 File Added: 2011-09-26 w2p gantt NZDST user.png
2011-10-21 15:05 caseydk Note Added: 0002263
2011-10-21 15:05 caseydk Status new => resolved
2011-10-21 15:05 caseydk Resolution open => fixed
2011-10-21 15:05 caseydk Assigned To => caseydk
2011-10-24 01:36 sasquatch58 Note Added: 0002265
2011-10-24 01:36 sasquatch58 Status resolved => feedback
2011-10-24 01:36 sasquatch58 Resolution fixed => reopened
2011-10-27 01:10 sasquatch58 File Added: GanttChart_21.pdf
2011-10-27 01:13 sasquatch58 Note Added: 0002267
2011-11-12 16:47 caseydk Note Added: 0002287
2011-11-12 16:47 caseydk Status feedback => resolved
2011-11-12 16:47 caseydk Resolution reopened => fixed
2013-08-28 11:13 caseydk Fixed in Version => 3.0.0
2013-08-28 11:24 caseydk Status resolved => closed
+Issue History