Anonymous Login
2019-04-24 15:22 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000990v3.0 Release[All Projects] Generalpublic2013-08-28 11:24
Reporterdananderson 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0000990: Importing tasks when source has dynamic tasks causes dependency issues.
DescriptionThis is similar to the issue that I saw in bug 0000620.

If I create a project and use dynamic tasks with child tasks and then try to clone that project by creating a new project and importing the tasks from the original project, the web page times out and I get a large number of dynamic tasks where there are no children and most of the children end up unrelated to the parent that they're supposed to be.

Create project SourceProject
Create task TaskParent1
Create task ChildTask
Make the parent for ChildTask TaskParent1
Create task TaskParent2
Create task ChildTask
Make the parent for ChildTask TaskParent2

In my case, I have 77 parent tasks, each with 3 child tasks.
TagsNo tags attached.
Attached Files

-Relationships
related to 0001064closedcaseydk Adding new tasks 
+Relationships

-Notes

~0002222

dananderson (reporter)

I just realized that I left off a few steps..

Make TaskParent tasks dynamic tasks.

Create a new project DestinationProject

Select to import tasks from SourceProject

In my case, there is a lot of corruption every time I've tried this.

~0002227

caseydk (administrator)

Could you try this with the v2.4 release, I believe this is resolved.

Thanks.

~0002241

dananderson (reporter)

I'll have to set up a dev box to do some testing on. I haven't looked at 2.4 for production yet due to all of the LDAP issues in the forums.

~0002276

dananderson (reporter)

This looks like it's still happening in 2.4

~0002277

dananderson (reporter)

For some of my larger projects (300-ish tasks, 25% of which are dynamic), I get

PHP Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/lib/adodb/adodb.inc.php on line 3283

in my logs.

I have a test box that's an 8-core box with 20GB of RAM and that seems to work ok if I bump up the max_execution_time to 120s. My one-core 3GHz box with 4 GB of RAM isn't happy with that, though. I've bumped up the Apache timeout and the PHP max_execution_time to over 300s, but the connection seems to die before it's finished processing.

~0002281

opto (manager)

I tried this scenario after fixing bug 993, and it seems to work for me.

Klaus

~0002282

opto (manager)

Title and description talk of two different things:
description says 'dynamic' was lost and importing screwed up. That is ok now
title says 'dependency issues': yes, dependencies of children of dynamic tasks don't work even in original project. I will make this a separate bug report as it seems to be independent of this

~0002293

dananderson (reporter)

By dependencies, I mean that if you go into the database and look at the new project, the task_parent is set to the task ID of the source project's task. There seems to be something in the code that is taking too long to process all of the tasks and set the task_parent to the right task ID. Per my previous notes, this seems to be very much dependent on the number of tasks and the horsepower of the box that it's running on.

~0002713

caseydk (administrator)

I *might* have solved this one by accident here:
https://github.com/caseysoftware/web2project/pull/171

All feedback welcome.

Regardless, I'm going to work on this more in the next day or two.

~0002740

caseydk (administrator)

Resolved: https://github.com/caseysoftware/web2project/pull/174
+Notes

-Issue History
Date Modified Username Field Change
2011-09-30 10:16 dananderson New Issue
2011-09-30 10:56 dananderson Note Added: 0002222
2011-10-01 22:38 caseydk Note Added: 0002227
2011-10-01 22:38 caseydk Status new => feedback
2011-10-05 03:09 dananderson Note Added: 0002241
2011-10-16 13:24 caseydk Project v2.2 Release (Closed) => v3.0 Release
2011-11-10 09:35 dananderson Note Added: 0002276
2011-11-10 10:29 dananderson Note Added: 0002277
2011-11-11 11:26 opto Note Added: 0002281
2011-11-11 11:50 opto Note Added: 0002282
2011-11-14 03:09 dananderson Note Added: 0002293
2012-02-19 01:07 robertbasic Relationship added related to 0001064
2012-11-24 22:58 caseydk Note Added: 0002713
2012-11-29 12:24 caseydk Note Added: 0002740
2012-11-29 12:24 caseydk Status feedback => resolved
2012-11-29 12:24 caseydk Resolution open => fixed
2012-11-29 12:24 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:24 caseydk Status resolved => closed
+Issue History