Anonymous Login
2019-02-21 16:53 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000993v3.0 Release[All Projects] Generalpublic2013-08-28 11:23
Reporterkareljj 
Assigned Toopto 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0000993: If more than one file is uploaded for a project only the last uploaded file is displayed as to be attached to the project.
DescriptionWhen a file is uploaded for a project, the first file works as expected, however from the second file onwards only the last file uploaded is displayed as file attachment in the system.




Additional InformationAll the files are in the \files\1\ directory on the server but only the last is displayed in the system.

The files table seems to have all the correct entries for all the files, although the field "file_indexed" has a value of 0.

The files_index table stay empty.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002254

miroslaw (reporter)

When I attach first file everything is ok.
When I attach second file, secon file is visible, but not first file, and I see that this file is in version 2.
And so on.
When I delete second file, first file is visible.

Please check this.
Attaching files do not work good.

Thanks!

~0002271

Korkonius (reporter)

I did an overhaul of some stuff related to the file module here. Among other things i discovered that the JS that was supposed to display/hide things did not work.

There where also some issues with mismatching of tags etc. in the folders_table.php file...

You could check if this issue is fixed in my current branch here:
https://github.com/Korkonius/web2project

~0002275

kareljj (reporter)

Hi Thank you for the reply but unfortunately the same problem persists.

If you upload a second file to the same task the system treat that as if it is a revision of the first file and not as a new file. This limits you to one file per task.

See attached screen-print.

It should allow one to upload more than one file per task and then to have revisions of certain files.

Thank you for your time and effort. Your system is making a difference in our environment.

~0002278

opto (manager)

reason is that file_versionid is not set.
I will try to find where that should be changed, Klaus

~0002279

opto (manager)

CFiles->store attempts to determine the last file_versio_id, unfortunately, it firs tsets the table (q->addtable(...) and then does the ckear on the query (q->clear(), so we don't have a table in the query and don't get the id. Thus, all are 1. -> single entry displayed only, and all files are parents of that.

~0002291

kareljj (reporter)

Hi, thank you for the feedback, sorry I do not understand, did you fix the problem or do you say it can't be fixed? If you have fixed it did you commit the changes yet?

I tested the latest build and the files are still doing the same. What is the way forward?

~0002292

opto (manager)

I have no access to SVN. You can fix it yourself until it is committed by the projectteam:

search for CFIle::store in files.class.php.

Look for
q->addtable(...)
followed by
q->clear()

reverse order to
q->clear()
q->addtable(...)

don't change the two lines, I have abbreviated them here, just change their order in the text.

That solved it for me,

Klaus

~0002294

kareljj (reporter)

Thank you!!!!

Work 100%

~0002338

kareljj (reporter)

Project team will it be possible to incorporate this fix into the SVN. The current version still has the same problem with files.

~0002367

caseydk (administrator)

Resolved as described in r2297;
+Notes

-Issue History
Date Modified Username Field Change
2011-10-12 00:37 kareljj New Issue
2011-10-18 04:35 miroslaw Note Added: 0002254
2011-11-09 01:12 Korkonius Note Added: 0002271
2011-11-10 09:08 kareljj File Added: files.jpg
2011-11-10 09:12 kareljj Note Added: 0002275
2011-11-11 09:22 opto Note Added: 0002278
2011-11-11 09:48 opto Note Added: 0002279
2011-11-11 09:48 opto Status new => resolved
2011-11-11 09:48 opto Resolution open => fixed
2011-11-11 09:48 opto Assigned To => opto
2011-11-13 22:44 kareljj Note Added: 0002291
2011-11-13 22:44 kareljj Status resolved => feedback
2011-11-13 22:44 kareljj Resolution fixed => reopened
2011-11-13 23:07 opto Note Added: 0002292
2011-11-14 04:26 kareljj Note Added: 0002294
2011-12-08 04:42 kareljj Note Added: 0002338
2011-12-27 23:01 caseydk Note Added: 0002367
2011-12-27 23:01 caseydk Status feedback => resolved
2011-12-27 23:01 caseydk Resolution reopened => fixed
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:23 caseydk Status resolved => closed
+Issue History